Bug 2112143

Summary: [RFE] Support startmsg.regex and endmsg.regex in the files inputs
Product: Red Hat Enterprise Linux 8 Reporter: Noriko Hosoi <nhosoi>
Component: rhel-system-rolesAssignee: Noriko Hosoi <nhosoi>
Status: CLOSED ERRATA QA Contact: David Jež <djez>
Severity: unspecified Docs Contact: Gabi Fialová <gfialova>
Priority: unspecified    
Version: 8.7CC: djez, gfialova, nhosoi, rmeggins, spetrosi
Target Milestone: rcKeywords: FutureFeature, Triaged
Target Release: 8.7   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: role:logging
Fixed In Version: rhel-system-roles-1.20.0-1.el8 Doc Type: Enhancement
Doc Text:
.The `logging` RHEL System Role supports options `startmsg.regex` and `endmsg.regex` in files inputs With this enhancement, you can now filter log messages coming from files by using regular expressions. Options `startmsg_regex` and `endmsg_regex` are now included in the files’ input. The `startmsg_regex` represents the regular expression that matches the start part of a message, and the `endmsg_regex` represents the regular expression that matches the last part of a message. As a result, you can now filter messages based upon properties such as date-time, priority, and severity.
Story Points: ---
Clone Of:
: 2112145 (view as bug list) Environment:
Last Closed: 2022-11-08 09:41:52 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 2112145    
Deadline: 2022-08-15   

Description Noriko Hosoi 2022-07-28 23:44:18 UTC
Description of problem:
Issue: https://github.com/linux-system-roles/logging/issues/284

Adds startmsg_regex and endmsg_regex options:
`startmsg_regex`: The regular expression that matches the start part of a message.
`endmsg_regex`: The regular expression that matches the last part of a message.

The test case to verify the feature is added to tests_combination.yml.

Comment 11 errata-xmlrpc 2022-11-08 09:41:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (rhel-system-roles bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2022:7568