Bug 2112410

Summary: Flatpack Gnome Todo gray screen
Product: [Fedora] Fedora Reporter: Larry Dewey <lardewey>
Component: gnome-todoAssignee: Igor Raits <igor.raits>
Status: CLOSED EOL QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: 36CC: amigadave, gnome-sig, ramu.rj
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Fixed In Version: Doc Type: ---
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2023-05-25 16:50:39 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Description Flags
gnome-todo-launched none

Description Larry Dewey 2022-07-29 15:43:42 UTC
Created attachment 1900164 [details]

Description of problem:
When attempting to launch Gnome TODO, only the window chrome is being drawn. It has a gray background, but there is no possibility of adding or removing tasks, settings, etc.

Version-Release number of selected component (if applicable):

How reproducible:
Attempt launch gnome-todo on Fedora 36

Steps to Reproduce:
1.Install gnome-todo (`sudo dnf -y install gnome-todo`)
2.Launch Todo from the graphical menu or from CLI

Actual results:
Gnome-todo launches, but is completely unusable. It has a gray screen, but nothing else.

Expected results:
Gnome-todo launches and is usable for keeping track of tasks which need to be done.

Additional info:

Full System information:
  Host: SCS-L10-lardewe.amd.com Kernel: 5.18.13-200.fc36.x86_64 arch: x86_64
    bits: 64 Desktop: GNOME v: 42.3.1 Distro: Fedora release 36 (Thirty Six)
  Type: Laptop System: HP product: HP EliteBook 845 G7 Notebook PC v: N/A
    serial: <superuser required>
  Mobo: HP model: 8760 v: KBC Version 07.30.00 serial: <superuser required>
    UEFI: HP v: S77 Ver. 01.05.00 date: 05/14/2021
  ID-1: BAT0 charge: 43.6 Wh (97.8%) condition: 44.6/53.2 Wh (83.7%)
  Info: 8-core model: AMD Ryzen 7 PRO 4750U with Radeon Graphics bits: 64
    type: MT MCP cache: L2: 4 MiB
  Speed (MHz): avg: 1396 min/max: 1400/1700 cores: 1: 1397 2: 1396 3: 1397
    4: 1397 5: 1397 6: 1396 7: 1397 8: 1397 9: 1397 10: 1397 11: 1397 12: 1397
    13: 1397 14: 1397 15: 1397 16: 1396
  Device-1: AMD Renoir driver: amdgpu v: kernel
  Device-2: Chicony HP HD Camera type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 22.1.3 driver: X:
    loaded: amdgpu unloaded: fbdev,modesetting,vesa gpu: amdgpu
    resolution: 1920x1080~60Hz
    renderer: AMD RENOIR (LLVM 14.0.0 DRM 3.46 5.18.13-200.fc36.x86_64)
    v: 4.6 Mesa 22.1.4
  Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: N/A
  Device-3: AMD Family 17h/19h HD Audio driver: snd_hda_intel
  Sound Server-1: ALSA v: k5.18.13-200.fc36.x86_64 running: yes
  Sound Server-2: PipeWire v: 0.3.56 running: yes
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi
  IF: wlp1s0 state: up mac: ec:63:d7:70:2a:83
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb
  Report: rfkill ID: hci0 state: up address: see --recommends
  Local Storage: total: 476.94 GiB used: 72.62 GiB (15.2%)
  ID-1: /dev/nvme0n1 vendor: SK Hynix model: BC511 HFM512GDJTNI-82A0A
    size: 476.94 GiB
  ID-1: / size: 118.34 GiB used: 72.32 GiB (61.1%) fs: btrfs dev: /dev/dm-0
  ID-2: /boot size: 973.4 MiB used: 296.2 MiB (30.4%) fs: ext4
    dev: /dev/nvme0n1p5
  ID-3: /boot/efi size: 498.7 MiB used: 14.1 MiB (2.8%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 118.34 GiB used: 72.32 GiB (61.1%) fs: btrfs
    dev: /dev/dm-0
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 42.0 C
  Fan Speeds (RPM): N/A
  Processes: 520 Uptime: 18h 38m Memory: 30.58 GiB used: 7.55 GiB (24.7%)
  Shell: Zsh inxi: 3.3.19

Comment 1 Ramu Rajasekharan 2022-08-14 13:16:11 UTC
It isn't a particularly flatpak bug. I installed gnome-todo from the Fedora rpms and I got the same screen. I tried restoring it to a smaller size using the keyboard shortcut and it resizes but the inside of the window remains blank.\
I tried launching from the terminal but on launching, gnome-todo frees/disconnects from the terminal and shows no messages.

Comment 2 Ben Cotton 2023-04-25 17:40:46 UTC
This message is a reminder that Fedora Linux 36 is nearing its end of life.
Fedora will stop maintaining and issuing updates for Fedora Linux 36 on 2023-05-16.
It is Fedora's policy to close all bug reports from releases that are no longer
maintained. At that time this bug will be closed as EOL if it remains open with a
'version' of '36'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, change the 'version' 
to a later Fedora Linux version. Note that the version field may be hidden.
Click the "Show advanced fields" button if you do not see it.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora Linux 36 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora Linux, you are encouraged to change the 'version' to a later version
prior to this bug being closed.

Comment 3 Ludek Smid 2023-05-25 16:50:39 UTC
Fedora Linux 36 entered end-of-life (EOL) status on 2023-05-16.

Fedora Linux 36 is no longer maintained, which means that it
will not receive any further security or bug fix updates. As a result we
are closing this bug.

If you can reproduce this bug against a currently maintained version of Fedora Linux
please feel free to reopen this bug against that version. Note that the version
field may be hidden. Click the "Show advanced fields" button if you do not see
the version field.

If you are unable to reopen this bug, please file a new report against an
active release.

Thank you for reporting this bug and we are sorry it could not be fixed.