Bug 2120550 (CVE-2022-35583)

Summary: CVE-2022-35583 wkhtmltopdf: wkhtmlTOpdf is vulnerable to Server-side request forgery (SSRF)
Product: [Other] Security Response Reporter: Sandipan Roy <saroy>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED UPSTREAM QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: lkundrak, mtasaka, nathanael
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-09-02 16:25:15 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 2120553, 2120552    
Bug Blocks: 2120416    

Description Sandipan Roy 2022-08-23 08:41:02 UTC
wkhtmlTOpdf 0.12.6 is vulnerable to SSRF which allows an attacker to get initial access into the target's system by injecting iframe tag with initial asset IP address on it's source. This allows the attacker to takeover the whole infrastructure by accessing their internal assets.

https://wkhtmltopdf.org/
https://drive.google.com/file/d/1LAmf_6CJLk5qDp0an2s_gVQ0TN2wmht5/view?usp=sharing
https://cyber-guy.gitbook.io/cyber-guys-blog/blogs/initial-access-via-pdf-file-silently

Comment 1 Sandipan Roy 2022-08-23 08:41:24 UTC
Created wkhtmltopdf tracking bugs for this issue:

Affects: epel-7 [bug 2120553]
Affects: fedora-all [bug 2120552]

Comment 2 Product Security DevOps Team 2022-09-02 16:25:13 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.