Bug 2120977

Summary: Non-responsive maintainer check for pkubat
Product: [Fedora] Fedora Reporter: Artem S. Tashkinov <aros>
Component: firejailAssignee: Orphan Owner <extras-orphan>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: rawhideCC: fedora, maxwell, odubaj, pkubat, remyabel
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-09-21 09:35:05 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Artem S. Tashkinov 2022-08-24 08:34:43 UTC
This bug is part of the non-responsive maintainer procedure for pkubat, following https://docs.fedoraproject.org/en-US/fesco/Policy_for_nonresponsive_package_maintainers/.

Please respond if you are still active in Fedora and want to maintain firejail.

Comment 1 Petr Kubat 2022-08-24 09:49:03 UTC
Hi Artem,

thanks for getting in contact! I was actually planning to ask if someone was interested in maintaining this package on fedora-devel as I will not have time for it in the near future. Guess you were faster. :)

Is my expectation that you are offering yourself to maintain the package correct?

Comment 2 Artem S. Tashkinov 2022-08-24 12:51:12 UTC
I've never maintained any packages in Fedora since it's just too much responsibility.

Please push an update, it's as easy as:

```
-Version: 0.9.66
-Release: 3%{?dist}
+Version: 0.9.70
+Release: 1%{?dist}

-Source0: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
+Source0: %{url}/archive/%{version}/%{name}-%{version}.tar.xz

-%doc README RELNOTES CONTRIBUTING.md
+%doc README RELNOTES
```

Thank you.

Comment 3 remyabel 2022-08-30 17:41:48 UTC
I have a COPR here: https://copr.fedorainfracloud.org/coprs/remyabel/firejail/

I agree that action needs to be taken because of the CVE. Maybe consider filing an issue on the FESCO tracker and see if anyone wants to take over the package?

Comment 4 Artem S. Tashkinov 2022-09-02 12:39:47 UTC
I really don't quite understand why three simple changes in the spec file require "maintenance".

I could have maintained the package but doing so requires going through a dozen circles of hell and I just don't want to.

Comment 5 remyabel 2022-09-02 16:56:00 UTC
Hi Artem,

I'm sorry about your frustration. Updating a package is not always a simple matter. It has to pass automated tests, QA (through bodhi), check if we need any patches, etc. 

I opened a FESCO issue here: https://pagure.io/fesco/issue/2864

No responses yet, but that issue tracker is probably where this discussion should be moved.

Comment 6 Maxwell G 2022-09-06 18:04:03 UTC
@pkubat, if you're not interested in maintaining this package, please orphan it.

Comment 7 Petr Kubat 2022-09-12 08:11:00 UTC
Hi folks, sorry for this taking so long. The package is orphaned now, so feel free to pick it up if you are interested in maintaining it.

Comment 8 Maxwell G 2022-09-12 21:09:35 UTC
(In reply to Petr Kubat from comment #7)
> Hi folks, sorry for this taking so long. The package is orphaned now, so
> feel free to pick it up if you are interested in maintaining it.

Ack. Thank you for your work up until now!

Comment 9 Artur Frenszek-Iwicki 2022-09-21 09:35:05 UTC
I've adopted the package. Closing this BZ as no longer relevant.

Thank you for your work so far, Petr.