Bug 2122157

Summary: some certbot commands still using deprecated v1 API
Product: [Fedora] Fedora Reporter: Peter Robinson <pbrobinson>
Component: certbotAssignee: Nick Bebout <nb>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 37CC: anon.amish, certbot-sig, james.hogarth, luk.claes, nb, nick, rbu
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: certbot-1.29.0-1.fc37 Doc Type: ---
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-09-12 17:43:03 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Peter Robinson 2022-08-29 11:19:17 UTC
When running some of the certbot sub commands it's still trying to use the deprecated v1 API endpoints which are now decommissioned: https://letsencrypt.org/docs/acme-protocol-updates/

certbot-1.27.0-3.fc37

$ certbot show_account
Saving debug log to /var/log/letsencrypt/letsencrypt.log
An unexpected error occurred:
requests.exceptions.ConnectionError: HTTPSConnectionPool(host='acme-v01.api.letsencrypt.org', port=443): Max retries exceeded with url: /acme/reg/4215639 (Caused by NewConnectionError('<urllib3.connection.HTTPSConnection object at 0x7f195005ce90>: Failed to establish a new connection: [Errno -2] Name or service not known'))
Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.

Comment 1 Fedora Update System 2022-08-30 17:07:56 UTC
FEDORA-2022-ad055b6d55 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-ad055b6d55

Comment 2 Fedora Update System 2022-08-31 02:21:56 UTC
FEDORA-2022-ad055b6d55 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-ad055b6d55`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-ad055b6d55

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 3 Fedora Update System 2022-09-12 17:43:03 UTC
FEDORA-2022-ad055b6d55 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.