Bug 212870

Summary: xend is severely broken on x86_64 on Fedora Core 5
Product: [Fedora] Fedora Reporter: Aleksander Adamowski <bugs-redhat>
Component: xenAssignee: Xen Maintainance List <xen-maint>
Status: CLOSED DUPLICATE QA Contact: Brian Brock <bbrock>
Severity: high Docs Contact:
Priority: medium    
Version: 5CC: bstein, katzj
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-10-29 18:11:46 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Aleksander Adamowski 2006-10-29 16:04:34 EST
Description of problem:

I'm running Xen on a x86_64 Opteron server (HP DL385).

Recently I've upgraded xend, libvirt, kernel to the following versions:

xen.x86_64 3.0.2-5.fc5
libvirt.x86_64 0.1.7-2.FC5
libvirt-python.x86_64 0.1.7-2.FC5
kernel-xen0.x86_64 2.6.18-1.2200.fc5

After stopping the guest domains and rebooting the physical domain 0, I've
discovered that Xen has stopped working at all.

There are the following errors in /var/log/xen/xend.log:

2006-10-29 20:54:56 xend 2683] INFO (SrvDaemon:283) Xend Daemon started
[2006-10-29 20:54:56 xend 2683] INFO (SrvDaemon:287) Xend changeset: unavailable .
[2006-10-29 20:54:56 xend 2683] ERROR (SrvDaemon:297) Exception starting xend
((111, 'Connection refused'))
Traceback (most recent call last):
  File "/usr/lib64/python2.4/site-packages/xen/xend/server/SrvDaemon.py", line
291, in run
    servers = SrvServer.create()
  File "/usr/lib64/python2.4/site-packages/xen/xend/server/SrvServer.py", line
108, in create
    root.putChild('xend', SrvRoot())
  File "/usr/lib64/python2.4/site-packages/xen/xend/server/SrvRoot.py", line 40,
in __init__
    self.get(name)
  File "/usr/lib64/python2.4/site-packages/xen/web/SrvDir.py", line 82, in get
    val = val.getobj()
  File "/usr/lib64/python2.4/site-packages/xen/web/SrvDir.py", line 52, in getobj
    self.obj = klassobj()
  File "/usr/lib64/python2.4/site-packages/xen/xend/server/SrvDomainDir.py",
line 39, in __init__
    self.xd = XendDomain.instance()
  File "/usr/lib64/python2.4/site-packages/xen/xend/XendDomain.py", line 636, in
instance
    inst.init()
  File "/usr/lib64/python2.4/site-packages/xen/xend/XendDomain.py", line 71, in init
    xstransact.Mkdir(VMROOT)
  File "/usr/lib64/python2.4/site-packages/xen/xend/xenstore/xstransact.py",
line 345, in Mkdir
    complete(path, lambda t: t.mkdir(*args))
  File "/usr/lib64/python2.4/site-packages/xen/xend/xenstore/xstransact.py",
line 351, in complete
    t = xstransact(path)
  File "/usr/lib64/python2.4/site-packages/xen/xend/xenstore/xstransact.py",
line 20, in __init__
    self.transaction = xshandle().transaction_start()
  File "/usr/lib64/python2.4/site-packages/xen/xend/xenstore/xsutil.py", line
18, in xshandle
    xs_handle = xen.lowlevel.xs.xs()
Error: (111, 'Connection refused')

/var/log/messages shows the following the same moment:

Oct 29 20:54:56 HOSTNAME xenstored: Checking store ...
Oct 29 20:54:56 HOSTNAME xenstored: Checking store complete.
Oct 29 20:54:56 HOSTNAME xenstored: Checking store ...
Oct 29 20:54:56 HOSTNAME xenstored: Checking store complete.

Since xen 3.0.2-5.fc5 is severely broken and kernel .2187_FC5 had serious
stability issues (see bug 199944), I had to go back to the latest
almost-stable-but-working configuration of kernel 2.6.17-1.2157_FC5xen0, xen
3.0.2-3.FC5 and libvirt-0.1.1-1.FC5.

How reproducible: always
Comment 1 Daniel Berrange 2006-10-29 18:11:46 EST

*** This bug has been marked as a duplicate of 211090 ***