Bug 2130415
| Summary: | python-starlette-0.21.0 is available | ||
|---|---|---|---|
| Product: | [Fedora] Fedora | Reporter: | Upstream Release Monitoring <upstream-release-monitoring> |
| Component: | python-starlette | Assignee: | Ben Beasley <code> |
| Status: | CLOSED ERRATA | QA Contact: | Fedora Extras Quality Assurance <extras-qa> |
| Severity: | unspecified | Docs Contact: | |
| Priority: | unspecified | ||
| Version: | rawhide | CC: | code |
| Target Milestone: | --- | Keywords: | FutureFeature, Triaged |
| Target Release: | --- | ||
| Hardware: | Unspecified | ||
| OS: | Unspecified | ||
| Whiteboard: | |||
| Fixed In Version: | python-starlette-0.21.0-1.fc38 | Doc Type: | If docs needed, set a value |
| Doc Text: | Story Points: | --- | |
| Clone Of: | Environment: | ||
| Last Closed: | 2022-10-20 12:26:46 UTC | Type: | --- |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
| Bug Depends On: | 2094511, 2116709 | ||
| Bug Blocks: | |||
|
Description
Upstream Release Monitoring
2022-09-28 06:21:36 UTC
After filtering out the pre-release greenlet 2.0 from requirements.txt, which we will just have to do without until greenlet 2.0 stable is released: No matching package to install: 'python3dist(databases) >= 0.6.1' No matching package to install: 'python3dist(databases[sqlite]) >= 0.6.1' No matching package to install: 'python3dist(trio) >= 0.21' No matching package to install: 'python3dist(typing-extensions) >= 4.3' (In reply to Ben Beasley from comment #1) > After filtering out the pre-release greenlet 2.0 from requirements.txt, > which we will just have to do without until greenlet 2.0 stable is released: > > No matching package to install: 'python3dist(databases) >= 0.6.1' > No matching package to install: 'python3dist(databases[sqlite]) >= 0.6.1' > No matching package to install: 'python3dist(trio) >= 0.21' > No matching package to install: 'python3dist(typing-extensions) >= 4.3' It turns out that these dependencies with versioning issues are generally test dependencies that were pinned in requirements.txt. The spec file was modifying that file to allow newer versions, but it turns out it is more appropriate to remove the version bounds from that file altogether. Version bounds that are not arbitrary will mostly be reflected in install_requires, etc. https://src.fedoraproject.org/rpms/python-starlette/pull-request/4 FEDORA-2022-48a3287747 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2022-48a3287747 FEDORA-2022-48a3287747 has been pushed to the Fedora 38 stable repository. If problem still persists, please make note of it in this bug report. |