Bug 213042

Summary: gnome-terminal cursor defaults to blinking
Product: [Fedora] Fedora Reporter: Adam Jackson <ajax>
Component: gnome-terminalAssignee: Behdad Esfahbod <behdad>
Status: CLOSED CURRENTRELEASE QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 10CC: bnocera, matthias, tim.liim, triage, walovaton
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-06-29 18:29:06 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 204948    

Description Adam Jackson 2006-10-30 12:38:44 EST
Description of problem:

Should default to not-blinking, avoids wakeup timers and the associated power cost.

Version-Release number of selected component (if applicable):

2.16.0-3.el5

How reproducible:

always
Comment 1 Behdad Esfahbod 2006-10-30 19:22:37 EST
There are quite a bunch of bugs in vte causing lots and lots of unnecessary
wakeups, but other than that, for cursor blinking we are changing gnome-terminal
to respect desktop-wide GNOME blinking settings, including the blink timeout.

Enforcing a default blink timeout of say 5min in gnome-settings-daemon or
whoever should be setting that is probably the way to go.
Comment 2 Adam Jackson 2007-04-25 13:06:40 EDT
Originally filed as a rhel bug, but moving to fedora.

Still blinking by default in F7t4.  /desktop/gnome/interface/cursor_blink_time
is 1200, which hopefully is in tenths of a second and therefore means 5 minutes,
but I still suggest that blinking at all is wrong.
Comment 3 Matthias Clasen 2007-04-25 19:31:00 EDT
We have the backported gtk patch to stop cursor blinking in entries and text
views after a minute. But we don't seem to have the corresponging vte patch.
Comment 4 Bug Zapper 2008-04-03 14:34:22 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 5 Bug Zapper 2008-05-06 20:58:41 EDT
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp
Comment 6 Bastien Nocera 2008-05-07 07:59:00 EDT
Still a problem in rawhide.
Comment 7 Bug Zapper 2008-05-13 22:26:27 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Tim Taiwanese Liim 2009-01-05 22:07:25 EST
This bug should be easy to fix.  Try the following:
- in the source tree, the file
        gnome-terminal-2.24.2/src/gnome-terminal.schemas.in
  change the key name
        /schemas/apps/gnome-terminal/profiles/Default/cursor_blink_mode
        string (type)
        system (default value)
  to 
        /schemas/desktop/gnome/interface/cursor_blink
        bool   (type)
        false  (default value)
  (I thought cursor_blink_mode is now obsolete, so 
  it's safe to replace it with cursor_blink.)
  (you may need to change owner translation, etc.)

Here is how I think it would work:
  - during rpmbuild the file 
        gnome-terminal-2.24.2/src/gnome-terminal.schemas.in   (#1)
    becomes
        ./BUILD/gnome-terminal-2.24.2/src/gnome-terminal.schemas (#2)
  - during "rpm -i" #2 becomes
          /etc/gconf/schemas/gnome-terminal.schemas (#3)
  - "rpm -q --scripts gnome-terminal" shows the 
    following postinstall scriplet:
        gconftool-2 ... /etc/gconf/schemas/gnome-terminal.schemas (#4)
    which reads the value from #3 and store it in
        /etc/gconf/gconf.xml.defaults/%gconf-tree.xml  (#5)
  - during run-time, gnome-terminal reads value from gconfd-2,
    which reads default values from #5.

I tried this in my private build, and it did the trick when I tried
it on my F10.

The same issue (cursor default to blinking) is still in F10 official
release.
Comment 9 Tim Taiwanese Liim 2009-01-28 17:29:36 EST
Does the proposal in Comment #8 make sense to you?
Comment 10 Tim Taiwanese Liim 2009-02-06 00:26:54 EST
Behdad,
How does the proposal in Comment #8 sounds to you?  Let me know
if anything can be improved.  Maybe we can finally close this 2+
year old bug in F11.
Comment 11 Behdad Esfahbod 2009-02-06 01:31:12 EST
Please raise the issue upstream.
Comment 12 Tim Taiwanese Liim 2009-04-05 01:57:33 EDT
Am I dreaming?  I installed F11 Beta and gnome-terminal cursor is
*not* blinking, by default.  Anyone seeing the same?
Comment 13 Matthias Saou 2009-04-19 13:43:14 EDT
(In reply to comment #12)
> Am I dreaming?  I installed F11 Beta and gnome-terminal cursor is
> *not* blinking, by default.  Anyone seeing the same?  

I can confirm. No blinking here either with Rawhide (F-11 freeze).
Comment 14 William Lovaton 2009-06-15 09:14:39 EDT
Yeah, it's not blinking by default, I think this bug report should be closed.
Comment 15 Tim Taiwanese Liim 2009-06-24 23:54:57 EDT
Behdad,
Now that this bug is fixed, why not just close it?
Thanks.
Comment 16 Behdad Esfahbod 2009-06-29 18:29:06 EDT
Suuuuuuuuuuuure.