Bug 2134668

Summary: Cannot edit ssh even vm is stopped
Product: Container Native Virtualization (CNV) Reporter: Guohua Ouyang <gouyang>
Component: User ExperienceAssignee: Hilda Stastna <hstastna>
Status: CLOSED ERRATA QA Contact: Guohua Ouyang <gouyang>
Severity: high Docs Contact:
Priority: high    
Version: 4.11.0CC: aturgema, cnv-qe-bugs, dcadzow, gouyang, hstastna, tnisan, ycui
Target Milestone: ---   
Target Release: 4.11.2   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 2117803 Environment:
Last Closed: 2022-12-01 21:12:19 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 2145030    
Bug Blocks:    
Attachments:
Description Flags
ssh error none

Comment 1 Guohua Ouyang 2022-10-25 01:16:30 UTC
The issue on 4.11.1 is the username is missing in the ssh command string while VM is stopped 
eg: ssh console-openshift-console.apps.uit-411-1024.cnv-qe.rhcloud.com -p 32522

Comment 2 Hilda Stastna 2022-10-25 13:36:00 UTC
Guohua,

to make that work, we need to merge https://github.com/kubevirt-ui/kubevirt-plugin/pull/893 and then to backport https://github.com/kubevirt-ui/kubevirt-plugin/pull/923 to 4.11,
but for now we are blocked, https://github.com/kubevirt-ui/kubevirt-plugin/pull/893 cannot be merged because of inconsistencies regarding target versions and some other problems that I cannot influence.

Comment 3 Hilda Stastna 2022-11-01 00:00:28 UTC
Note that we still need to backport https://github.com/kubevirt-ui/kubevirt-plugin/pull/923 to 4.11,
to fix what Guohua has mentioned in Comment 1.

Comment 4 Hilda Stastna 2022-11-01 13:27:17 UTC
PR with the backport of https://github.com/kubevirt-ui/kubevirt-plugin/pull/923 waiting to get merged:
https://github.com/kubevirt-ui/kubevirt-plugin/pull/940

Comment 5 Guohua Ouyang 2022-11-15 09:16:08 UTC
It cannot enable the ssh service if the service exists with error:
"services "rhel8-bare-stoat-ssh-service" already exists"

Steps:
1. create the vm and enable the ssh service while the VM is running
2. disable the ssh service
3. stop the VM
4. enable ssh service, error happens

Comment 6 Hilda Stastna 2022-11-21 18:05:16 UTC
Hi Guohua,

is the problem mentioned in the Comment 5 still reproducible? If yes, what kind of error occurs? Can you add more info? Thanks.

Comment 7 Hilda Stastna 2022-11-21 22:11:30 UTC
To be more specific why needinfo, I was not able to reproduce on 4.11 (uit-411-1118).
I was able to enable/disable the ssh service whenever I wanted - when VM was running or not, without any issues.

Comment 8 Guohua Ouyang 2022-11-22 12:13:08 UTC
Created attachment 1926384 [details]
ssh error

Attach the video I took on cluster uit-411-1118

Comment 9 Hilda Stastna 2022-11-22 15:40:53 UTC
Guohua, 

to make that work, we need to clone this BZ https://bugzilla.redhat.com/show_bug.cgi?id=2100442 to 4.11
and to backport https://github.com/kubevirt-ui/kubevirt-plugin/pull/756 to the appropriate branch.
Can you clone the BZ? Thanks.

Comment 10 Guohua Ouyang 2022-11-23 00:24:46 UTC
(In reply to Hilda Stastna from comment #9)
> Guohua, 
> 
> to make that work, we need to clone this BZ
> https://bugzilla.redhat.com/show_bug.cgi?id=2100442 to 4.11

Cloned the bug to 4.11: https://bugzilla.redhat.com/show_bug.cgi?id=2145030
> and to backport https://github.com/kubevirt-ui/kubevirt-plugin/pull/756 to

It needs to create the backport PR manually as it cannot be done automatically.

> the appropriate branch.
> Can you clone the BZ? Thanks.

Comment 11 Hilda Stastna 2022-11-23 13:03:17 UTC
Guohua,

thanks for the info and for cloning the bug. And the backport PR done by Ugo https://github.com/kubevirt-ui/kubevirt-plugin/pull/983 was already merged. Thanks.

Comment 12 Guohua Ouyang 2022-11-24 02:05:04 UTC
verified on v4.11.1-19

Comment 20 errata-xmlrpc 2022-12-01 21:12:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Moderate: OpenShift Virtualization 4.11.1 security and bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2022:8750