Bug 2143727

Summary: [abrt] pipewire-pulseaudio: core_sync.isra.0(): pipewire-pulse killed by SIGSEGV
Product: [Fedora] Fedora Reporter: bitchecker <ciro.deluca>
Component: pipewireAssignee: Wim Taymans <wtaymans>
Status: CLOSED EOL QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 37CC: brunovern.a, derdunkleherrscher, information, wtaymans
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
URL: https://retrace.fedoraproject.org/faf/reports/bthash/449d81f4f4fc2d8321d581c4afebbef31cdcad56
Whiteboard: abrt_hash:85226a5e2112b9a46432af92e26f9c9f50443408;VARIANT_ID=xfce;
Fixed In Version: Doc Type: ---
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2023-12-06 11:26:46 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Description Flags
File: backtrace
File: core_backtrace
File: cpuinfo
File: dso_list
File: environ
File: exploitable
File: limits
File: maps
File: mountinfo
File: open_fds
File: proc_pid_status none

Description bitchecker 2022-11-17 16:47:38 UTC
Version-Release number of selected component:

Additional info:
reporter:       libreport-2.17.4
backtrace_rating: 4
cgroup:         0::/user.slice/user-1000.slice/session-2.scope
cmdline:        pipewire-pulse
crash_function: core_sync.isra.0
executable:     /usr/bin/pipewire-pulse
journald_cursor: s=c1592f43dad2423d8f4b00a673f8e283;i=1999;b=26274d3fbc27451b82a2c041cb8ef4ca;m=76d23ae2f;t=5edad2a7dd2ac;x=4eb7c13ca4741d11
kernel:         6.0.8-300.fc37.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 core_sync.isra.0 at ../src/modules/module-protocol-pulse/manager.c:91
 #1 pw_manager_sync at ../src/modules/module-protocol-pulse/manager.c:933
 #2 operation_new_cb at ../src/modules/module-protocol-pulse/operation.c:51
 #3 sample_play_stream_state_changed at ../src/modules/module-protocol-pulse/sample-play.c:57
 #4 stream_set_state at ../src/pipewire/stream.c:388
 #5 impl_send_command at ../src/pipewire/stream.c:608
 #6 impl_node_send_command at ../spa/plugins/audioconvert/audioadapter.c:834
 #7 idle_node at ../src/pipewire/impl-node.c:195
 #8 pw_impl_node_set_state at ../src/pipewire/impl-node.c:2211
 #9 client_node_command at ../src/modules/module-client-node/remote-node.c:516

Potential duplicate: bug 2090664

Comment 1 bitchecker 2022-11-17 16:47:41 UTC
Created attachment 1925058 [details]
File: backtrace

Comment 2 bitchecker 2022-11-17 16:47:42 UTC
Created attachment 1925059 [details]
File: core_backtrace

Comment 3 bitchecker 2022-11-17 16:47:43 UTC
Created attachment 1925060 [details]
File: cpuinfo

Comment 4 bitchecker 2022-11-17 16:47:44 UTC
Created attachment 1925061 [details]
File: dso_list

Comment 5 bitchecker 2022-11-17 16:47:45 UTC
Created attachment 1925062 [details]
File: environ

Comment 6 bitchecker 2022-11-17 16:47:46 UTC
Created attachment 1925063 [details]
File: exploitable

Comment 7 bitchecker 2022-11-17 16:47:47 UTC
Created attachment 1925064 [details]
File: limits

Comment 8 bitchecker 2022-11-17 16:47:48 UTC
Created attachment 1925065 [details]
File: maps

Comment 9 bitchecker 2022-11-17 16:47:49 UTC
Created attachment 1925066 [details]
File: mountinfo

Comment 10 bitchecker 2022-11-17 16:47:50 UTC
Created attachment 1925067 [details]
File: open_fds

Comment 11 bitchecker 2022-11-17 16:47:51 UTC
Created attachment 1925068 [details]
File: proc_pid_status

Comment 12 derdunkleherrscher 2023-01-19 13:39:18 UTC
Similar problem has been detected:

I've created this thread to get help.
I also described there what I've done so far and what happened ("symptoms occurred") afterwards of these things,
which I've tried.


reporter:       libreport-2.17.4
backtrace_rating: 4
cgroup:         0::/user.slice/user-1000.slice/user/session.slice/pipewire-pulse.service
cmdline:        /usr/bin/pipewire-pulse
crash_function: core_sync.isra.0
executable:     /usr/bin/pipewire-pulse
journald_cursor: s=76d09bea78d94796bafa3c5f498c71b7;i=b2abb;b=01ceac9a4539454aa69c04d40ce33f50;m=1b1441e85;t=5f29ce170a41f;x=be2981633805969c
kernel:         6.1.6-200.fc37.x86_64
package:        pipewire-pulseaudio-0.3.64-1.fc37
reason:         pipewire-pulse killed by SIGSEGV
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 13 derdunkleherrscher 2023-01-24 14:28:43 UTC
NEWS: I gave up on the headset because it turned out, that it's the fault of Astro' hardware. We've tested anything possible to make it work (https://ask.fedoraproject.org/t/headset-not-working-properly-astro-a20-newbie-needs-help/30869) but no matter what we've tried, nothing worked. Astro should really improve in that simple thing: A plug & "play" headset. That's it, no need anymore to review this bug except you want to BUT I'm gone then. Bye.

Comment 14 Aoife Moloney 2023-11-23 00:31:57 UTC
This message is a reminder that Fedora Linux 37 is nearing its end of life.
Fedora will stop maintaining and issuing updates for Fedora Linux 37 on 2023-12-05.
It is Fedora's policy to close all bug reports from releases that are no longer
maintained. At that time this bug will be closed as EOL if it remains open with a
'version' of '37'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, change the 'version' 
to a later Fedora Linux version. Note that the version field may be hidden.
Click the "Show advanced fields" button if you do not see it.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora Linux 37 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora Linux, you are encouraged to change the 'version' to a later version
prior to this bug being closed.

Comment 15 Aoife Moloney 2023-12-06 11:26:46 UTC
Fedora Linux 37 entered end-of-life (EOL) status on None.

Fedora Linux 37 is no longer maintained, which means that it
will not receive any further security or bug fix updates. As a result we
are closing this bug.

If you can reproduce this bug against a currently maintained version of Fedora Linux
please feel free to reopen this bug against that version. Note that the version
field may be hidden. Click the "Show advanced fields" button if you do not see
the version field.

If you are unable to reopen this bug, please file a new report against an
active release.

Thank you for reporting this bug and we are sorry it could not be fixed.