Bug 214641 (CVE-2006-5794)

Summary: CVE-2006-5794 OpenSSH privilege separation flaw
Product: [Fedora] Fedora Reporter: Josh Bressers <bressers>
Component: opensshAssignee: Tomas Mraz <tmraz>
Status: CLOSED ERRATA QA Contact: Brian Brock <bbrock>
Severity: low Docs Contact:
Priority: medium    
Version: 6Keywords: Security
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://www.openssh.com/txt/release-4.5
Whiteboard: source=vendorsec,reported=20061107,impact=low,public=20061107
Fixed In Version: openssh-4.3p2-10.0.fc6 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-11-20 11:28:10 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Josh Bressers 2006-11-08 13:57:01 EST
+++ This bug was initially created as a clone of Bug #214640 +++

OpenSSH has fixed a minor flaw that could allow a remote attacker to bypass
normal authentication mechanisms if a flaw is ever found that allows an attacker
to control the unprivileged process when privilege separation is enabled.

This flaw is not exploitable by itself.  It requires a flaw which allows the
attacker to control the unprivileged process while privilege seperation is enabled.

This issue also affects FC5
Comment 1 Fedora Update System 2006-11-10 10:09:10 EST
openssh-4.3p2-10.0.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 2 Fedora Update System 2006-11-20 11:55:25 EST
openssh-4.3p2-10.0.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.