Bug 214944

Summary: Ejecting CD requires pressing eject button twice
Product: [Fedora] Fedora Reporter: The Source <thesource>
Component: gnome-volume-managerAssignee: David Zeuthen <davidz>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6CC: mclasen
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 2.15.0-4.fc6 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-01-07 03:39:54 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description The Source 2006-11-10 02:02:19 EST
Description of problem:
When I press eject button on my DWD-RW once, error message appears: "Cannot
eject volume <volume name>". Only when I press eject button the second time, CD
ejects successfully

Version-Release number of selected component (if applicable):
I'm not sure what component this bug is related to, but I have latest versions
of all components

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 The Source 2006-11-11 06:34:04 EST
It happens only with second or higher number devices if 2 or more CD drives
present in system. With primary device it works properly
Comment 2 The Source 2006-11-16 05:54:13 EST
This bug may be related to #206592
Comment 3 The Source 2006-11-21 07:42:23 EST
If I press Eject in context menu, error message appears
"Error ejecting CD: can not remove directory". But in 2 seconds drive ejects
though. May be system tries to delete directory before unmounting? Or maybe
directory was created with improper permissions?
Comment 4 Marc Thompson 2006-11-28 10:58:24 EST
I'm experiencing pretty much the same problem with FC6 in GNOME:

When I try to eject a CD by right clicking on its desktop icon and selecting
"eject," I get the message "Cannot Unmount Volume."

When I click on the "Details" button in the above message box, I get the
following message: "Cannot remove directory."

Then when I click on the "OK" button, the CD ejects.

I have 2 optical drives (/dev/hdc and /dev/hdd), and the eject problem occurs
only with the first (/dev/hdc).
Comment 5 The Source 2006-11-28 12:44:19 EST
My problem is with the second device (/dev/hdd). Are your problem device master
or slave?. Which device did you install later?
Comment 6 Marc Thompson 2006-11-29 22:06:31 EST
(In reply to comment #5)
> My problem is with the second device (/dev/hdd). Are your problem device master
> or slave?. Which device did you install later?

My problem device is the master, /dev/hdc.
/dev/hdd is my slave and does whatever I tell it to do.
I installed /dev/hdd after /dev/hdc

Could this problem have anything to do with symlinks???
Comment 7 The Source 2006-11-30 01:11:46 EST
I had this idea too. I'll check /dev/cdrom, /dev/dvd etc links (what targets do
they have). Please do the same.
Comment 8 Marc Thompson 2006-11-30 13:09:44 EST
Symlinks for /dev/cdrom, /dev/dvd, etc.  Does anything seem out of the ordinary
here to you?

Script started on Thu 30 Nov 2006 11:52:11 AM CST
     

$ ls -ls /dev/cdrom

lrwxrwxrwx 1 root root 3 Nov 30 11:12 /dev/cdrom -> hdc


$ ls -la /dev/cdrom-hdc

lrwxrwxrwx 1 root root 3 Nov 30 11:12 /dev/cdrom-hdc -> hdc


$ ls -la /dev/cdrom-hdd

lrwxrwxrwx 1 root root 3 Nov 30 11:12 /dev/cdrom-hdd -> hdd


$ ls -la /dev/cdrw

lrwxrwxrwx 1 root root 3 Nov 30 11:12 /dev/cdrw -> hdd


$ ls -la /dev/cdrw-hdd

lrwxrwxrwx 1 root root 3 Nov 30 11:12 /dev/cdrw-hdd -> hdd


$ ls -la /dev/cdwriter

lrwxrwxrwx 1 root root 3 Nov 30 11:12 /dev/cdwriter -> hdd


$ ls -la /dev/cdwriter-hdd

lrwxrwxrwx 1 root root 3 Nov 30 11:12 /dev/cdwriter-hdd -> hdd

    

$ ls -la /dev/dvd

lrwxrwxrwx 1 root root 3 Nov 30 11:12 /dev/dvd -> hdc


$ ls -la /dev/dvd-hdc

lrwxrwxrwx 1 root root 3 Nov 30 11:12 /dev/dvd-hdc -> hdc


$ ls -la /dev/dvd-hdd

lrwxrwxrwx 1 root root 3 Nov 30 11:12 /dev/dvd-hdd -> hdd


$ ls -la /dev/dvdrw

lrwxrwxrwx 1 root root 3 Nov 30 11:12 /dev/dvdrw -> hdd


$ ls -la /dev/dvdrw-hdd

lrwxrwxrwx 1 root root 3 Nov 30 11:12 /dev/dvdrw-hdd -> hdd


$ ls -la /dev/dvdrwriter

lrwxrwxrwx 1 root root 3 Nov 30 11:12 /dev/dvdwriter -> hdd


$ ls -la /dev/dvdwriter-hdd

lrwxrwxrwx 1 root root 3 Nov 30 11:12 /dev/dvdwriter-hdd -> hdd



Script done on Thu 30 Nov 2006 11:54:52 AM CST
Comment 9 Marc Thompson 2006-11-30 13:28:02 EST
My apologies for the output format in the previous post.  Here it is in more
condensed, readable format:
lrwxrwxrwx 1 root root 3 Nov 30 11:12 /dev/cdrom -> hdc

lrwxrwxrwx 1 root root 3 Nov 30 11:12 /dev/cdrom-hdc -> hdc

lrwxrwxrwx 1 root root 3 Nov 30 11:12 /dev/cdrom-hdd -> hdd

lrwxrwxrwx 1 root root 3 Nov 30 11:12 /dev/cdrw -> hdd

lrwxrwxrwx 1 root root 3 Nov 30 11:12 /dev/cdrw-hdd -> hdd

lrwxrwxrwx 1 root root 3 Nov 30 11:12 /dev/cdwriter -> hdd

lrwxrwxrwx 1 root root 3 Nov 30 11:12 /dev/cdwriter-hdd -> hdd  

lrwxrwxrwx 1 root root 3 Nov 30 11:12 /dev/dvd -> hdc

lrwxrwxrwx 1 root root 3 Nov 30 11:12 /dev/dvd-hdc -> hdc

lrwxrwxrwx 1 root root 3 Nov 30 11:12 /dev/dvd-hdd -> hdd

lrwxrwxrwx 1 root root 3 Nov 30 11:12 /dev/dvdrw -> hdd

lrwxrwxrwx 1 root root 3 Nov 30 11:12 /dev/dvdrw-hdd -> hdd

lrwxrwxrwx 1 root root 3 Nov 30 11:12 /dev/dvdwriter -> hdd

lrwxrwxrwx 1 root root 3 Nov 30 11:12 /dev/dvdwriter-hdd -> hdd

Comment 10 The Source 2006-11-30 13:59:32 EST
0 lrwxrwxrwx 1 root root 3 Nov 30 21:49 /dev/cdrom -> hdd
0 lrwxrwxrwx 1 root root 3 Nov 30 21:49 /dev/dvd -> hdd

It looks like main common links point to problem device. I'm not sure how it can
be connected but it looks like this problem related to symlinks really.
Comment 11 The Source 2006-12-11 09:31:44 EST
For me this bug disappeared after latesrt updates. Can you confirm this?
Comment 12 The Source 2007-01-07 03:39:54 EST
No responce recieved, but works for me. Closing.