Bug 215194

Summary: gnome-terminal/vte: no repaint for new tabs (i.e. app feels frozen)
Product: [Fedora] Fedora Reporter: Saikat Guha <sg266>
Component: gnome-terminalAssignee: Behdad Esfahbod <behdad>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: dakingun
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-12-22 10:46:10 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Repaint bug for gnome-terminal 2.16.1-1.fc7 / vte 0.14.1-1.fc7 none

Description Saikat Guha 2006-11-12 02:45:23 EST
Description of problem:
New tabs opened in gnome terminal do not get regular repaints. There is no
blinking cursor in tabs two onwards. Typing commands on the shell doesn't show
up (although the command is run) in these tabs. Running commands doesn't produce
any output. Moving another window on top of gnome-terminal and moving it away to
force a repaint shows the expected output in the damaged region.

Version-Release number of selected component (if applicable):
gnome-terminal-2.16.1-1.fc7
vte-0.14.1-1.fc7


How reproducible:
Always

Steps to Reproduce:
1. Open gnome-terminal
2. Open new tab (ctrl-shift-T)
3. Type commands into new tab. Nothing shows up
  
Actual results:
New tab may show up black temporarily (not repainted to white) or may come up
white. In either case, typing commands doesn't show anything although the
command is run. Moving windows on top to force a repaint exposes the result.
Only for tabs 2 onwards. See screenshot. 

Expected results:
Regular repaint of all tabs.

Additional info:
 Fully patched rawhide 
 x86_64 
 metacity 
 nvidia-binary-drivers
Comment 1 Saikat Guha 2006-11-12 02:45:23 EST
Created attachment 140981 [details]
Repaint bug for gnome-terminal 2.16.1-1.fc7 / vte 0.14.1-1.fc7
Comment 2 Jeremy Katz 2006-12-22 10:46:10 EST

*** This bug has been marked as a duplicate of 218139 ***