Bug 2158922

Summary: Namespace store fails to get created via the ODF UI
Product: [Red Hat Storage] Red Hat OpenShift Data Foundation Reporter: bmcmurra
Component: management-consoleAssignee: Ivo Almeida <ialmeida>
Status: CLOSED ERRATA QA Contact: Vishakha Kathole <vkathole>
Severity: high Docs Contact:
Priority: unspecified    
Version: 4.11CC: kbg, muagarwa, ocs-bugs, odf-bz-bot, skatiyar, tdesala, usrivast
Target Milestone: ---   
Target Release: ODF 4.13.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: 4.13.0-207 Doc Type: Bug Fix
Doc Text:
.User interface correctly passes the PVC name to the CR Previously, while creating NamespaceStore in the user interface (UI) using file system, the UI would pass the entire PVC object to the CR instead of just the PVC name that is required to be passed to the CR's `spec.nsfs.pvcName` field. As a result, an error was seen on the UI. With this fix, only the PVC name is passed to the CR instead of the entire PVC object.
Story Points: ---
Clone Of:
: 2161652 (view as bug list) Environment:
Last Closed: 2023-06-21 15:23:05 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 2154341, 2161652, 2161655    

Comment 24 Sanjal Katiyar 2023-05-18 07:47:32 UTC
I am increasing severity as this should be fixed in 4.13 itself !

Comment 25 Sanjal Katiyar 2023-05-23 12:12:26 UTC
upstream PR: https://github.com/red-hat-storage/odf-console/pull/850

Comment 28 errata-xmlrpc 2023-06-21 15:23:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Red Hat OpenShift Data Foundation 4.13.0 enhancement and bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2023:3742