This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 217378

Summary: gnome-terminal crashes
Product: [Fedora] Fedora Reporter: Jonathan Corbet <corbet>
Component: gnome-terminalAssignee: Behdad Esfahbod <behdad>
Status: CLOSED CANTFIX QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: rawhideCC: steve, triage
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: bzcl34nup
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-04-05 11:49:33 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Jonathan Corbet 2006-11-27 11:46:53 EST
Description of problem:

gnome-terminal will crash after running for some time (typically a couple of
days).  Often the crash happens first thing in the morning after the screen
saver gets out of the way - i.e. the terminal gets an expose event, but no other
interaction happens.

It's worth noting that I usually have a window running "tail -f" on a logfile
running, so there is a steady stream of text scrolling there.  Also worth noting
is that the process size increases visibly over a short period of time:

corbet   14974  0.0  2.3 295520 24288 ?        Rsl  07:54   0:02 gnome-terminal
corbet   14974  0.0  2.4 296180 24868 ?        Ssl  07:54   0:03 gnome-terminal

This was over the time it has taken me to fill in the bug report.

Version-Release number of selected component (if applicable):

gnome-terminal-2.16.1-1.fc7.


How reproducible:

Always happens eventually.

Steps to Reproduce:
1. Start session with gnome-terminal
2. Wait for crash
3.
  
Actual results:

Crashes.

Expected results:

No crash.

Additional info:
Comment 1 Jim Treadway 2006-12-07 16:38:15 EST
I think there is a pretty bad memory leak, probably related to scrollback
buffering or terminal output.  I usually have quite a few terminals open, and
after a day or two my swap is completely exhausted, eventually causing
gnome-terminal to crash.

Here's my 'ps' output:

jim      12629  0.3 22.2 654176 230092 ?       Sl   Dec04  14:19 gnome-terminal

The numbers hold steady if there is no terminal output.  After doing an 'ls -lR'
in a fairly large source directory, I get:

jim      12629  0.3 27.8 654176 288272 ?       Sl   Dec04  14:52 gnome-terminal
Comment 2 Andrew Overholt 2007-03-07 22:49:31 EST
I just installed F7 test2 and updated to rawhide and now gnome-terminal crashes
on startup for me.  How do we go about debugging this?
Comment 3 Andrew Overholt 2007-03-08 09:08:21 EST
Bah, sorry for the noise.  I think our problems are different (and I'm not on
x86_64).
Comment 4 Jim Treadway 2007-04-19 16:08:12 EDT
I'm not on x86_64, but I think that my problem is the same.
Comment 5 Steve Hill 2007-04-25 06:13:22 EDT
I have 2 FC6 machines here (one x86_64, one x86) - after a recent update I find
ctrl+shift+N sometimes causes all my gnome terms to crash.

I'm running gnome-terminal-2.16.0-2.fc6 under Beryl.  My .xsession-errors shows:


The program 'gnome-terminal' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 39083 error_code 8 request_code 62 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)


I understand the arguements for using a single process to run all the windows,
but it's a really bad thing to see 20 terminal windows all explode at the same
time (especially since they explode in a ball of flames thanks to Beryl's fire
effect :)
Comment 6 Matthias Clasen 2007-04-25 08:26:44 EDT
can you do what the output asks you to do, and run 

gdb --args gnome-terminal --sync

and then report the resulting stacktrace, please ?
Comment 7 Steve Hill 2007-04-26 04:57:29 EDT
I am currently running my gnome terms in gdb.  However, the crashes are
infrequent so I may not be able to produce a stack dump any time soon.
Comment 8 Steve Hill 2007-05-03 05:58:02 EDT
This looks like it may be a different problem, but it still resulted in a crash.
 Unfortunately gdb hasn't produced any especially useful output:

(gdb) break gdk_x_error
Function "gdk_x_error" not defined.
Make breakpoint pending on future shared library load? (y or [n]) y

Breakpoint 1 (gdk_x_error) pending.
(gdb) run
Starting program: /usr/bin/gnome-terminal --sync
[Thread debugging using libthread_db enabled]
[New Thread 46912496366048 (LWP 8895)]
[New Thread 1084229952 (LWP 8903)]
[New Thread 1094719808 (LWP 8997)]
[New Thread 1105209664 (LWP 8998)]
[Thread 1105209664 (LWP 8998) exited]
[Thread 1094719808 (LWP 8997) exited]
[New Thread 1094719808 (LWP 8999)]
[New Thread 1105209664 (LWP 9000)]
[Thread 1094719808 (LWP 8999) exited]
[Thread 1105209664 (LWP 9000) exited]

(gnome-terminal:8895): Vte-WARNING **: No handler for control sequence
`device-control-string' defined.
Couldn't get registers: No such process.
(gdb) bt
Couldn't get registers: No such process.
(gdb) 
Comment 9 Bug Zapper 2008-04-03 14:42:35 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 10 Steve Hill 2008-04-04 04:11:25 EDT
Not seen this happen in a recent Fedora.
Comment 11 Matthias Clasen 2008-04-05 11:49:33 EDT
Keeping this bug open doesn't seem very productive. I'm going to close it now.
If you witness a gnome-terminal crash in current releases, just file a new one,
please.