Bug 217705

Summary: Logging in with nis with a nfs home directory directories are not recognized as such
Product: [Fedora] Fedora Reporter: Igor Pesando <ipesando>
Component: nfs-utilsAssignee: Steve Dickson <steved>
Status: CLOSED DUPLICATE QA Contact: Ben Levenson <benl>
Severity: high Docs Contact:
Priority: medium    
Version: 6CC: ipesando
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-03-12 16:21:19 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Igor Pesando 2006-11-29 10:01:27 EST
Description of problem:

The system is nis+ based with nfs home directory.

If I mount the fs as a NFSv2 it seems to work 
while if I mount it as NFSv3 I get the following problem.

When I log in with nis and I write 
ls <directory name>
the system answers by saing it is not a directory and 
nfsstat -m
shows that <directory name> is  mounted as a piece of the filesystem
while df, cat mtab do not show anything strange.


Version-Release number of selected component (if applicable):
nfs-utils 1.0.10

How reproducible:

I tried with two computers and both showed the problem.
What is wierd is that with the first computer the problem disappered once
upgraded while with the second it appeared.

Anyhow, once the problem shows up it is always reproducible.

It happens both with a ssh login and with a console login.

Steps to Reproduce:
1. log in with nis
2. ls .kde  => error ".kde" is not a directory
3. nfsstam -m shows:
  

[root@to45xl ~]# nfsstat -m
/users/usr04 from diskserver.to.infn.it:/users/usr04
 Flags:
rw,sync,vers=3,rsize=32768,wsize=32768,acregmin=0,acregmax=0,acdirmin=0,acdirmax=0,hard,noac,proto=udp,timeo=11,retrans=2,sec=sys,addr=diskserver.to.infn.it

/users/usr04/ipesando/.kde/share from
diskserver.to.infn.it:/users/usr04/ipesando/.kde/share
 Flags:
rw,sync,vers=3,rsize=32768,wsize=32768,acregmin=0,acregmax=0,acdirmin=0,acdirmax=0,hard,noac,proto=udp,timeo=11,retrans=2,sec=sys,addr=diskserver.to.infn.it

/users/usr04/ipesando/.mozilla from
diskserver.to.infn.it:/users/usr04/ipesando/.mozilla
 Flags:
rw,sync,vers=3,rsize=32768,wsize=32768,acregmin=0,acregmax=0,acdirmin=0,acdirmax=0,hard,noac,proto=udp,timeo=11,retrans=2,sec=sys,addr=diskserver.to.infn.it

/users/usr04/ipesando/.kde/tmp-to49xl.to.infn.it from
diskserver.to.infn.it:/users/usr04/ipesando/.kde/tmp-to49xl.to.infn.it
 Flags:
rw,sync,vers=3,rsize=32768,wsize=32768,acregmin=0,acregmax=0,acdirmin=0,acdirmax=0,hard,noac,proto=udp,timeo=11,retrans=2,sec=sys,addr=diskserver.to.infn.it

/users/usr04/ipesando/.kde/tmp-to4sxl.to.infn.it from
diskserver.to.infn.it:/users/usr04/ipesando/.kde/tmp-to4sxl.to.infn.it
 Flags:
rw,sync,vers=3,rsize=32768,wsize=32768,acregmin=0,acregmax=0,acdirmin=0,acdirmax=0,hard,noac,proto=udp,timeo=11,retrans=2,sec=sys,addr=diskserver.to.infn.it

/users/usr04/ipesando/.kde/Autostart from
diskserver.to.infn.it:/users/usr04/ipesando/.kde/Autostart
 Flags:
rw,sync,vers=3,rsize=32768,wsize=32768,acregmin=0,acregmax=0,acdirmin=0,acdirmax=0,hard,noac,proto=udp,timeo=11,retrans=2,sec=sys,addr=diskserver.to.infn.it



Actual results:


Expected results:

to see the content of the directory

Additional info:

It did not happen with previous realeses (FC5, FC4...)
Comment 1 Steve Dickson 2007-03-12 13:43:26 EDT
What server are you using? 
Comment 2 Igor Pesando 2007-03-12 15:42:32 EDT
Compaq Tru64 UNIX V5.1A (Rev. 1885)
Comment 3 Steve Dickson 2007-03-12 16:21:19 EDT
I thought so... this is a know problem with Tru64 servers....
Duping this bug to bz220451

*** This bug has been marked as a duplicate of 220451 ***