Bug 218478

Summary: GFS2 and ACL bug?
Product: Red Hat Enterprise Linux 5 Reporter: Kiersten (Kerri) Anderson <kanderso>
Component: kernelAssignee: Steve Whitehouse <swhiteho>
Status: CLOSED CURRENTRELEASE QA Contact: Dean Jansa <djansa>
Severity: medium Docs Contact:
Priority: medium    
Version: 5.0CC: cattelan, dzickus, lwang, rpeterso, swhiteho, wcheng
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: RC Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-02-08 01:21:28 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 217129    
Bug Blocks:    

Description Kiersten (Kerri) Anderson 2006-12-05 18:08:36 UTC
+++ This bug was initially created as a clone of Bug #217129 +++

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20061107
Fedora/ Firefox/

Description of problem:

Got this (see attachment to this bz) after mounting the gfs2 volume with acl
option.  Not really sure if it is new or related to my previous deadlock
problems, but thought I better submit it.  Maybe your latest patches are not in
this kernel and this is taken care of in your tree.  I was doing a couple finds.
 You will all see a sysreq dump included in case it helps.  Runnig devel
version, kernel kernel-devel-2.6.18-1.2849.fc6 and the latest updates to cman,
clvm, openais, etc.

FWIW, the find process is hung chewing through 100% CPU, I assume spinning on a

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Sorta reproducible (intermittant)

1.  Mount gfs2 volume with acl?
2.  use find to find a file

Actual Results:
Find a file (or not) with kernel errors

Expected Results:
Find a file (or not) without kernel errors///

Additional info:

-- Additional comment from gplindstrom@fiberpipe.net on 2006-11-24 02:09 EST --
Created an attachment (id=142039)
Kernel errors for gfs2 with ACL mount option

Kernel errors and sysreq dump of problem...

-- Additional comment from swhiteho@redhat.com on 2006-11-24 07:08 EST --
This is caused by some incorrect logic when checking the acl which hasn't
correctly worked out whether the inode is already locked or not and has tried to
lock it again. I'll try to come up with a patch shortly.

-- Additional comment from swhiteho@redhat.com on 2006-11-27 04:48 EST --
I've just pushed a patch to the -nmw git tree to fix this problem.

-- Additional comment from swhiteho@redhat.com on 2006-11-28 07:00 EST --
This is the URL of the fix:


I would have posted it yesterday, but it seems that kernel.org is very slow to
update these days. You can get a plain version from the "plain" link at the top
of the web page.

Comment 1 RHEL Product and Program Management 2006-12-05 18:32:00 UTC
Quality Engineering Management has reviewed and declined this request.  You may
appeal this decision by reopening this request. 

Comment 2 Kiersten (Kerri) Anderson 2006-12-05 18:52:06 UTC
Hit the wrong button on the flag that caused the inadvertant close state.

Comment 3 Steve Whitehouse 2006-12-06 08:50:37 UTC
This is the URL for the patch for this bug, the commit id has changed since I
last posted the URL, but the patch is the same:


Comment 4 RHEL Product and Program Management 2006-12-07 15:06:58 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update

Comment 5 Don Zickus 2006-12-14 01:06:57 UTC
in 2.6.18-1.2876.el5

Comment 6 RHEL Product and Program Management 2007-02-08 01:21:28 UTC
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.