Bug 2186171

Summary: [GSS] "disableLoadBalancerService: true" config is reconciled after modifying the number of NooBaa endpoints
Product: [Red Hat Storage] Red Hat OpenShift Data Foundation Reporter: hhuan
Component: Multi-Cloud Object GatewayAssignee: Liran Mauda <lmauda>
Status: CLOSED ERRATA QA Contact: Tiffany Nguyen <tunguyen>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.10CC: kbg, kramdoss, lmauda, nbecker, ocs-bugs, odf-bz-bot, tdesala
Target Milestone: ---   
Target Release: ODF 4.13.0   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Previously, any change to the `disableLoadBalancerService` field for Multicloud Object Gateway (MCG) was overridden due to the OpenShift Data Foundation operator reconciliation. With this fix, reconcile of `disableLoadBalancerService` field is ignored in OpenShift Data Foundation operator and, as a result, any value set for this field in NooBaa CR is retained and not overridden.
Story Points: ---
Clone Of: Environment:
Last Closed: 2023-06-21 15:25:03 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 2154341    

Comment 10 Tiffany Nguyen 2023-05-09 06:03:37 UTC
On ODF 4.13 (build 4.13.0-179), when disableLoadBalancerService: true, there are no services for s3 and sts as below:
$ oc get service -n openshift-storage
NAME                                               TYPE        CLUSTER-IP       EXTERNAL-IP   PORT(S)                            AGE
csi-addons-controller-manager-metrics-service      ClusterIP   172.30.88.84     <none>        8443/TCP                           6d9h
csi-addons-controller-manager-service              ClusterIP   172.30.46.33     <none>        443/TCP                            4d11h
csi-addons-webhook-service                         ClusterIP   172.30.132.195   <none>        443/TCP                            6d9h
noobaa-db-pg                                       ClusterIP   172.30.11.7      <none>        5432/TCP                           6d9h
noobaa-mgmt                                        ClusterIP   172.30.106.176   <none>        80/TCP,443/TCP,8445/TCP,8446/TCP   6d9h
noobaa-operator-service                            ClusterIP   172.30.207.50    <none>        443/TCP                            5h5m
ocs-metrics-exporter                               ClusterIP   172.30.186.70    <none>        8080/TCP,8081/TCP                  6d9h
odf-console-service                                ClusterIP   172.30.91.131    <none>        9001/TCP                           6d9h
odf-operator-controller-manager-metrics-service    ClusterIP   172.30.89.91     <none>        8443/TCP                           6d9h
rook-ceph-exporter                                 ClusterIP   172.30.208.52    <none>        9926/TCP                           6d9h
rook-ceph-mgr                                      ClusterIP   172.30.73.212    <none>        9283/TCP                           6d9h
rook-ceph-mon-a                                    ClusterIP   172.30.201.16    <none>        3300/TCP                           6d9h
rook-ceph-mon-b                                    ClusterIP   172.30.9.250     <none>        3300/TCP                           6d9h
rook-ceph-mon-c                                    ClusterIP   172.30.164.120   <none>        3300/TCP                           6d9h
rook-ceph-rgw-ocs-storagecluster-cephobjectstore   ClusterIP   172.30.61.118    <none>        80/TCP,443/TCP                     6d9h
s3                                                 ClusterIP   172.30.140.22    <none>        80/TCP,443/TCP,8444/TCP,7004/TCP   6d9h
sts                                                ClusterIP   172.30.58.213    <none>        443/TCP                            6d9h


When disableLoadBalancerService: false, the services are in pending state:
$ oc get service -n openshift-storage
NAME                                               TYPE           CLUSTER-IP       EXTERNAL-IP   PORT(S)                                                    AGE
csi-addons-controller-manager-metrics-service      ClusterIP      172.30.88.84     <none>        8443/TCP                                                   6d9h
csi-addons-controller-manager-service              ClusterIP      172.30.46.33     <none>        443/TCP                                                    4d11h
csi-addons-webhook-service                         ClusterIP      172.30.132.195   <none>        443/TCP                                                    6d9h
noobaa-db-pg                                       ClusterIP      172.30.11.7      <none>        5432/TCP                                                   6d9h
noobaa-mgmt                                        ClusterIP      172.30.106.176   <none>        80/TCP,443/TCP,8445/TCP,8446/TCP                           6d9h
noobaa-operator-service                            ClusterIP      172.30.207.50    <none>        443/TCP                                                    5h9m
ocs-metrics-exporter                               ClusterIP      172.30.186.70    <none>        8080/TCP,8081/TCP                                          6d9h
odf-console-service                                ClusterIP      172.30.91.131    <none>        9001/TCP                                                   6d9h
odf-operator-controller-manager-metrics-service    ClusterIP      172.30.89.91     <none>        8443/TCP                                                   6d9h
rook-ceph-exporter                                 ClusterIP      172.30.208.52    <none>        9926/TCP                                                   6d9h
rook-ceph-mgr                                      ClusterIP      172.30.73.212    <none>        9283/TCP                                                   6d9h
rook-ceph-mon-a                                    ClusterIP      172.30.201.16    <none>        3300/TCP                                                   6d9h
rook-ceph-mon-b                                    ClusterIP      172.30.9.250     <none>        3300/TCP                                                   6d9h
rook-ceph-mon-c                                    ClusterIP      172.30.164.120   <none>        3300/TCP                                                   6d9h
rook-ceph-rgw-ocs-storagecluster-cephobjectstore   ClusterIP      172.30.61.118    <none>        80/TCP,443/TCP                                             6d9h
s3                                                 LoadBalancer   172.30.140.22    <pending>     80:30484/TCP,443:30951/TCP,8444:30774/TCP,7004:31243/TCP   6d9h
sts                                                LoadBalancer   172.30.58.213    <pending>     443:31011/TCP                                              6d9h

Comment 16 errata-xmlrpc 2023-06-21 15:25:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Red Hat OpenShift Data Foundation 4.13.0 enhancement and bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2023:3742