Bug 218762

Summary: [fix available] RFE: Make spell-checking use system hunspell dictionaries
Product: [Fedora] Fedora Reporter: Caolan McNamara <caolanm>
Component: xulrunnerAssignee: Gecko Maintainer <gecko-bugs-nobody>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: caillon, dwmw2, fedora, johnp, kim-rh, stransky, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-03-04 10:10:03 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 207571, 235705    
Attachments:
Description Flags
now theoretically just boils down to this I believe none

Description Caolan McNamara 2006-12-07 07:45:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061027 Firefox/2.0

Description of problem:
Move firefox (and thunderbird etc) away from the internal myspell implementation and use a hunspell one linked to system hunspell

i.e. the patch at http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=401969 does this. Though change hunspell lib name to the fedora one


Version-Release number of selected component (if applicable):
firefox-2.0-2.fc7

How reproducible:
Always


Steps to Reproduce:
.

Actual Results:


Expected Results:


Additional info:
Comment 1 Matthias Clasen 2007-04-04 00:36:53 EDT
Is this still on the agenda for FC7 ? I thought spell unification was one of the
FC7 features ?
Comment 2 Thorsten Leemhuis 2007-04-15 08:34:20 EDT
(In reply to comment #1)
> Is this still on the agenda for FC7? 

I'd say it should, but the feature freeze is quite near :-/ But the current
situation is quite annoying -- I always have to update the link to the german
dictionary manually...

Caillon, can we help with anything or are your working on making firefox and
thunderbird hunspell aware?


Comment 3 Christopher Aillon 2007-04-15 13:34:47 EDT
Nemeth has been working on it.  The situation basically is that it's not
upstream yet.  I'm not going to commit to putting in a feature prior to
upstream's acceptance of it, esp. since we're using Firefox as a devel
environment and this will cause a change in API/ABI.

Still, it might be something we have to do as an FC7 update.
Comment 4 Christopher Aillon 2007-04-15 13:35:26 EDT
https://bugzilla.mozilla.org/show_bug.cgi?id=hunspell has the current status btw.
Comment 5 Thorsten Leemhuis 2007-04-16 01:30:20 EDT
(In reply to comment #3)
> Nemeth has been working on it.  The situation basically is that it's not
> upstream yet. [...]

Thanks for the update Caillon.

Well, if we don't get hunspell in by F7 would it be possible to link all
installed  dictionaries from %{_datadir}/myspell/ to
%{_libdir}/thunderbird-*/dictionaries/ and %{_libdir}/firefox-*/dictionaries/?
That's a bad hack, I know, but then the dictionaries (and thus spell checking)
would at least be available by default for non-us languages.
Comment 6 Caolan McNamara 2007-04-16 02:46:06 EDT
I'm not certain that this is safe to do, hunspell can understand myspell
dictionaries and many of the hunspell dictionaries are still just in that
myspell format. But some are in hunspell format which I don't think is
guaranteed backwards compatible with myspell. 

So while it'll definitely work for some dictionaries, it's quite possible that
some of them might not work when firefox's myspell attempts to open a hunspell
dictionary. Much safer to just link the entire firefox/thunderbird dictionary
dirs to the /usr/share/myspell once firefox uses hunspell.
Comment 7 Thorsten Leemhuis 2007-04-16 02:50:57 EDT
(In reply to comment #6)
> I'm not certain that this is safe to do, hunspell can understand myspell
> dictionaries and many of the hunspell dictionaries are still just in that
> myspell format. But some are in hunspell format which I don't think is
> guaranteed backwards compatible with myspell. [...]

k, then it was a bad idea :-/ Thanks for clarifying 
Comment 8 Caolan McNamara 2007-12-19 15:05:05 EST
xulrunner now contains these dictionaries now as well

> rpm -ql xulrunner|grep dictionaries
/usr/lib/xulrunner-1.9b2pre/dictionaries/en-US.aff
/usr/lib/xulrunner-1.9b2pre/dictionaries/en-US.dic

my understanding looking at the code is that in firefox3 the spellchecking is
removed from firefox and remains in xulrunner and that (a copy of) hunspell is
in use by xulrunner, and the code has a fallback from XX-YY.[dic|aff] to
XX_YY.[dic|aff] so that should allow us to now just directly use our hunspell
dictionary of /usr/share/myspell instead as per the attached trivial patch
against the xulrunner.spec 
Comment 9 Caolan McNamara 2007-12-19 15:06:21 EST
Created attachment 290052 [details]
now theoretically just boils down to this I believe
Comment 10 Christopher Aillon 2007-12-20 10:39:56 EST
Need to potentially also figure out if we need to take something like:
https://bugzilla.mozilla.org/show_bug.cgi?id=339123

At the least, we probably need it to recognize the Mozilla brands.
Comment 11 Caolan McNamara 2007-12-20 11:04:33 EST
"Gage", hah, like thats a work. But for the brands, see
http://qa.openoffice.org/issues/show_bug.cgi?id=56389 so that should be ok.

Though the last actual release of the dictionaries doesn't seem to have them in
it while the ones in cvs do, so I need to get the upstream standalone en_US dict
synced with the bundled into OOo one to sort that out, but that's minor.
Comment 12 Matěj Cepl 2008-03-10 07:28:57 EDT
*** Bug 202403 has been marked as a duplicate of this bug. ***