Bug 218807

Summary: Xen Virtual Machine Manager fails to create Virtual Machine
Product: [Fedora] Fedora Reporter: Douglas Furlong <bugzilla_rhn>
Component: xenAssignee: Daniel Berrange <berrange>
Status: CLOSED NOTABUG QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 6CC: bstein, katzj, xen-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-12-07 12:49:30 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Description Flags
Virt Manager Log none

Description Douglas Furlong 2006-12-07 11:52:45 EST
Description of problem:
When trying to create a virtual machine using the Xen Virtual Machine Manager,
the command fails at the point of hitting "finish"

Version-Release number of selected component (if applicable):

How reproducible:
Currently 100%

Steps to Reproduce:
1. Go through the process of creating a virtual Machine and hit finish
Actual results:
The following error is generated.
Traceback (most recent call last):
  File "/usr/lib64/python2.4/site-packages/xen/xend/server/SrvDomainDir.py",
line 77, in op_create
    dominfo = self.xd.domain_create(config)
  File "/usr/lib64/python2.4/site-packages/xen/xend/XendDomain.py", line 228, in
    dominfo = XendDomainInfo.create(config)
  File "/usr/lib64/python2.4/site-packages/xen/xend/XendDomainInfo.py", line
195, in create
  File "/usr/lib64/python2.4/site-packages/xen/xend/XendDomainInfo.py", line
1363, in initDomain
    raise VmError(str(exn))
VmError: (22, 'Invalid argument')

Expected results:
Virtual Machine to be created, and installation proceed.

Additional info:
This is on an AMD 64 Bit System.
Installation to a LVM Volume created specifically for the task (preformated as

Installation media specified as NFS, with the relevant locations.

Please let me know if any additional info is required.
Comment 1 Douglas Furlong 2006-12-07 11:55:42 EST
The same error message appears to be generated when attempting to create the
Virtual Machine as a file on the existing file system, or an unformated LVM Volume.
Comment 2 Daniel Berrange 2006-12-07 12:02:23 EST
The  'Invalid argument'  method either means you tried to boot a bare-metal
kernel, or a non-PAE  enabled kernel.

What OS are you trying to install ?

Please attach the contents of /root/.virt-manager/virt-manager.log from
immediately after you get this message.
Comment 3 Douglas Furlong 2006-12-07 12:47:37 EST

I am trying to install FC6 i386.

I've attached the file requested.
Comment 4 Douglas Furlong 2006-12-07 12:49:17 EST
Created attachment 143072 [details]
Virt Manager Log
Comment 5 Daniel Berrange 2006-12-07 12:49:30 EST
You can't install a 32-bit  paravirt guest, on a 64-bit host with Xen - the
HyperVisor does not support the mixed arch in paravirt mode.

If you want to run mixed architecture like that, you'll need to do a fully-virt
/ HVM install of the 32-bit guest.
Comment 6 Daniel Berrange 2006-12-07 12:51:45 EST
BTW, quick timesaving tip  wrt...

> Installation to a LVM Volume created specifically for the task (preformated as

There is no need to pre-format the partition in Dom0 - you can simply create the
bare logical volume. When anaconda runs in the guest OS installer it will
partition the LV, and format it as needed.
Comment 7 Douglas Furlong 2006-12-07 12:52:14 EST
Ahhh, okay.

However, the fully-virt option is grayed out, due to lack of support.

When I was saying what I was doing, it suddenly dawned on me that it may be a
slight issue. Sorry for the wasted time.

Though, is it not possible for a more informative error?
Comment 8 Daniel Berrange 2006-12-07 12:54:39 EST
The problem is that  XenD  currently only gives back 'Invalid argument' when
creation fails. We're actively working with upstream Xen developers to get
significantly improved error reporting incorporated into XenD, which would let
us tell user exactly what went wrong.