Bug 218813

Summary: Changing the default time source from PMtimer to TSC
Product: Red Hat Enterprise Linux 5 Reporter: Bhavna Sarathy <bnagendr>
Component: kernelAssignee: Red Hat Kernel Manager <kernel-mgr>
Status: CLOSED DUPLICATE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: high    
Version: 5.0CC: bnagendr
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-12-15 15:29:13 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Bhavna Sarathy 2006-12-07 12:32:50 EST
Description of problem:
The default PMtimer is not scalable and performance numbers with Oracle timed 
& non-timed stats do not give the customer a good out of the box experience.
With GH TSC will be the default timer and the code is in RHEL5, so the 
change/discussion is for the Opterons with the TSCnow patch.

(The modified kernel in reference here is cpuid(0) instruction added to the 
RDTSCP code path to simulate the GH latencies).

With modified kernel to simulate GH latencies:

                        HPET         TSC            TSC vs HPET

w/ No timed Stats      36251.6       41675.40       1.15

W/ timed Stats         34419.2       40342.80        1.17

%diff                     5.3%              3.3%

 

w/ no timed stats:  TSC is 15% faster than HPET

w/ timed stats: TSC is 17% faster than HPET


Beta2 kernel:

Oracle 10G         HPET     PMtimer      TSC    TSC vs PMtimer    TSC vs HPET

w/ notimed stat     37454     39495     43947        1.11             1.17

timed stats         32968     33995     42096        1.24             1.27

 % diff              13.6%    16.18%    4.4%  

 

w/ notimed Stats  - 11% faster than pmtimer, and 17% faster than HPET 

w/ timed Stats on - 24% faster than pmtimer, and 27% faster than HPET
Comment 1 Adam Jackson 2006-12-15 15:29:13 EST

*** This bug has been marked as a duplicate of 218814 ***