Bug 2207837

Summary: libcxx-16.0.4 is available
Product: [Fedora] Fedora Reporter: Upstream Release Monitoring <upstream-release-monitoring>
Component: libcxxAssignee: Tom "spot" Callaway <spotrh>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: npopov, serge.guelton, siddharth.kde, spotrh, tstellar, tuliom
Target Milestone: ---Keywords: FutureFeature, Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: libcxx-16.0.4-1.fc38 Doc Type: ---
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2023-05-25 01:11:27 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Upstream Release Monitoring 2023-05-17 05:27:58 UTC
Releases retrieved: 16.0.4
Upstream release that is considered latest: 16.0.4
Current version/release in rawhide: 16.0.3-1.fc39
URL: http://libcxxabi.llvm.org/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/11491/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/libcxx

Comment 1 Upstream Release Monitoring 2023-05-17 05:28:02 UTC
Scratch build failed. Details below:

DownloadException: There is a syntax error in updated specfile. See attached diff for the changes.
Traceback:
  File "/usr/local/lib/python3.11/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.11/site-packages/hotness/builders/koji.py", line 201, in build
    new_sources = self._spec_sources(specfile, tmp)
                  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.11/site-packages/hotness/builders/koji.py", line 337, in _spec_sources
    raise DownloadException(msg)

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 2 Fedora Update System 2023-05-20 19:58:36 UTC
FEDORA-2023-20c50d366a has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-20c50d366a

Comment 3 Fedora Update System 2023-05-20 20:46:29 UTC
FEDORA-2023-20c50d366a has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 4 Fedora Update System 2023-05-23 14:23:13 UTC
FEDORA-2023-421f8b8f93 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-421f8b8f93

Comment 5 Fedora Update System 2023-05-24 14:19:14 UTC
FEDORA-2023-421f8b8f93 has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-421f8b8f93`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-421f8b8f93

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2023-05-25 01:11:27 UTC
FEDORA-2023-421f8b8f93 has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.