Bug 221133

Summary: Cannot download http://download.fedora.redhat.com/pub/fedora/linux/core/development/source/SRPMS/repodata/repomd.xml although it is there...
Product: Red Hat Enterprise Linux 5 Reporter: Matěj Cepl <mcepl>
Component: yumAssignee: Jeremy Katz <katzj>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-01-02 08:02:12 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Matěj Cepl 2007-01-02 06:21:14 EST
Description of problem:
yum has troubles to read development-source repository, although curl sees it
without problems. IMHO, there is no http cache involved and I made yum clean all
 just before running this:

sh-3.1# curl -O
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   951  100   951    0     0   2674      0 --:--:-- --:--:-- --:--:-- 59437
sh-3.1# less repomd.xml 
sh-3.1# ls -lh
total 24K
drwxr-xr-x 2 root root 4,0K led  2 12:04 headers
drwxr-xr-x 2 root root 4,0K led  2 12:04 packages
-rw-r--r-- 1 root root  951 led  2 12:17 repomd.xml
sh-3.1# yum --enablerepo=development-source,development list totem\*
Loading "skip-broken" plugin
Loading "protectbase" plugin
Loading "rhnplugin" plugin
Loading "changelog" plugin
Loading "priorities" plugin
Loading "installonlyn" plugin
Setting up repositories
rhel-i386-client-5-beta   100% |=========================|  951 B    00:00     
[Errno 14] HTTP Error 404: Not Found
Trying other mirror.
Error: Cannot open/read repomd.xml file for repository: development-source

Version-Release number of selected component (if applicable):

How reproducible:
just now tried 5 times and yum always failed.

Steps to Reproduce:
1.see above
Comment 1 Matěj Cepl 2007-01-02 08:02:12 EST
Probably some old .repo file (missing /source/ part of URL).