Bug 2227

Summary: Installs from local hard disk still fail if RedHat is not in the root directory
Product: [Retired] Red Hat Linux Reporter: Theodore Tso <tytso>
Component: abootAssignee: Cristian Gafton <gafton>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-06-06 16:31:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Theodore Tso 1999-04-17 04:52:13 UTC
Using the Beta4 images, RPMS's and base files, I tried
placing everything from gribble/beta4/i386 in the /RH
dirctory of my DOS/VFAT filesystem (since installing off of
a PCMCIA SCSI device still doesn't work).  So at install
time, I specified that I was installing off local disk, I
specified /dev/hda1 as the filesystem (which was my VFAT
filesystem), and /RH as the directory path to the RedHat
programs.  This failed, with RedHat saying it couldn't find
the installation directories.

I then moved /RH/RedHat to the top level (i.e., /) of the
VFAT filesystem, and then tried specifying /dev/hda1 and /
as the location for the local repository for RPM files.
This time, it worked.  So think there is still something
faulty in the logic around that code, however.

Comment 1 Jeff Johnson 1999-06-06 16:31:59 UTC
This sounds like it's been fixed in Red Hat 6.0. Please reopen if I'm
wrong.