Bug 223201

Summary: Error: method "xend.domain.getSysMem" is not supported while running "xm list"
Product: [Fedora] Fedora Reporter: Egon Kastelijn <redhat2>
Component: xenAssignee: Xen Maintainance List <xen-maint>
Status: CLOSED NOTABUG QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 6CC: bstein, katzj
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-01-18 10:09:25 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Egon Kastelijn 2007-01-18 07:38:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.9) Gecko/20061219 Fedora/1.5.0.9-1.fc6 Firefox/1.5.0.9 pango-text

Description of problem:
The command "xm list" does not work anymore.
It used to work with xen-3.0.3-1.fc6, but it stopped working after then yum update I did to xen-3.0.3-3.fc6.



Version-Release number of selected component (if applicable):
kernel-2.6.18-1.2869.fc6xen,  xen-3.0.3-3.fc6

How reproducible:
Always


Steps to Reproduce:
1. run 'xm list'

Actual Results:
[root@hostname bin]# xm list
Name                                      ID Mem(MiB) VCPUs State   Time(s)
Error: method "xend.domain.getSysMem" is not supported
Usage: xm list [options] [Domain, ...]

List information about all/some domains.
  -l, --long                     Output all VM details in SXP
  --label                        Include security labels

[root@hostname bin]#

Expected Results:
A normal list of Xen domain should be displayed.

Additional info:
Comment 1 Egon Kastelijn 2007-01-18 07:39:56 EST
The commands 'xm create' and 'xm shutdown' work fine.
Comment 2 Egon Kastelijn 2007-01-18 07:50:47 EST
"xm log" shows:

[2007-01-18 13:46:05 xend 4915] ERROR (xmlrpclib2:184) method
"xend.domain.getSysMem" is not supported
Traceback (most recent call last):
  File "/usr/lib64/python2.4/site-packages/xen/util/xmlrpclib2.py", line 162, in
_marshaled_dispatch
    response = self._dispatch(method, params)
  File "/usr/lib64/python2.4/SimpleXMLRPCServer.py", line 408, in _dispatch
    raise Exception(\047method "%s" is not supported\047 % method)
Exception: method "xend.domain.getSysMem" is not supported
Comment 3 Daniel Berrange 2007-01-18 09:07:07 EST
The 'getSysMem' method is a new XML-RPC call added to XenD to let it report the
actual guest memory usage, rather than merely the assigned usage. Since this is
a new method though, it will be neccessary to restart XenD after installation of
the update. The RPM does not do this automatically, because restarting XenD can
have a detrimental impact on any running guests, and also on the host networking.

Anyway, can you confirm that the 'xm list' command works correctly again after
restarting the xend service.
Comment 4 Egon Kastelijn 2007-01-18 10:05:13 EST
My deepest appologies..
:)

Problem solved!
(closure code: USER FAULT)
;)