Bug 223802

Summary: Radeon DRI hangs the machine with i586 kernel
Product: [Fedora] Fedora Reporter: Bastien Nocera <bnocera>
Component: xorg-x11-drv-atiAssignee: Adam Jackson <ajax>
Status: CLOSED INSUFFICIENT_DATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6Keywords: Reopened
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-05-26 15:10:08 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Bastien Nocera 2007-01-22 10:46:16 EST
1. Install a stock FC6 on a Centrino based laptop with a r300 series chipset
2. Verify that anaconda (wrongly) installs the i586 kernel
3. Machine will hang on bootup with DRI enabled.

"Fix" was to add this line to /etc/modprobe.conf:
alias radeon off

DRI and 3D worked great once the i686 kernel was being used.
Comment 1 Matěj Cepl 2007-01-23 11:59:47 EST

*** This bug has been marked as a duplicate of 211941 ***
Comment 2 Bastien Nocera 2007-01-23 12:32:55 EST
Matej, I know about the "anaconda picks i586 kernel" bug. That's not the point
of this bug. Rather it is about finding out why Radeon wouldn't work with the
i586 kernel (which it should, really).
Comment 3 Matěj Cepl 2007-01-24 03:09:01 EST
OK, let's return to standard ways of doing things. Could you please attach to
this bug report your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) as individual uncompressed file attachments using the
bugzilla file attachment link below?

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

Sorry for the confusion.
Comment 5 Adam Jackson 2007-05-26 15:10:08 EDT
Mass closure: This bug has been in NEEDINFO for over six weeks with no
additional information provided, and is therefore being closed.  If this bug is
still an issue for you, please supply the requested information, and reopen the bug.