Bug 2238320

Summary: "Alder Lake-UP3 GT2 [Iris Xe Graphics]" - HDMI-port not working
Product: [Fedora] Fedora Reporter: pri20
Component: xorg-x11-drv-intelAssignee: Adam Jackson <ajax>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 38CC: ajax, ofourdan
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Fixed In Version: Doc Type: ---
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2024-01-16 21:23:16 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Description Flags
dmesg | grep i915
Some Error-Messages from the System-Log none

Description pri20 2023-09-11 12:57:50 UTC
The HDMI-port of my iGPU is not working. The CPU is "i5-1235U" and the iGPU is "Alder Lake-UP3 GT2 [Iris Xe Graphics]".

Have tried several Linux-distros, its the same everywhere. If i plugin a second display, there is no response. In Windows 11 its fully functional.

Reproducible: Always

Distro                      Fedora 38 Workstation
Desktop Environment         Wayland
Compositor                  mutter

Installed Modules:
intel-gpu-firmware.noarch   20230804-153.fc38           @updates 
intel-mediasdk.x86_64       23.2.2-1.fc38               @updates 
oneVPL-intel-gpu.x86_64     23.1.3-2.fc38               @anaconda
xorg-x11-drv-intel.x86_64   2.99.917-55.20210115.fc38   @anaconda

Comment 1 pri20 2023-09-11 13:04:37 UTC
Created attachment 1988138 [details]
dmesg | grep i915

Comment 2 pri20 2023-09-11 13:05:13 UTC
Created attachment 1988139 [details]

Comment 4 pri20 2023-09-11 13:13:14 UTC
Created attachment 1988154 [details]

Comment 5 pri20 2023-09-11 13:16:01 UTC
Created attachment 1988155 [details]
Some Error-Messages from the System-Log

Comment 6 pri20 2024-01-15 21:04:00 UTC
Same thing on Fedora 39

Installed Modules:
intel-gpu-firmware.noarch                        20231211-1.fc39                                  @updates 
intel-mediasdk.x86_64                            23.2.2-2.fc39                                    @anaconda
oneVPL-intel-gpu.x86_64                          23.3.4-2.fc39                                    @updates 
xorg-x11-drv-intel.x86_64                        2.99.917-56.20210115.fc39                        @anaconda

Comment 7 pri20 2024-01-16 21:22:28 UTC
The Problem is solved in my case by updating the UEFI-Firmware. Now it works like expected :o)