Bug 2244592

Summary: llvm-17.0.3 is available
Product: [Fedora] Fedora Reporter: Upstream Release Monitoring <upstream-release-monitoring>
Component: llvmAssignee: Tom Stellard <tstellar>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: dmalcolm, jakub, jchecahi, jistone, kkleine, npopov, scottt.tw, serge.guelton, siddharth.kde, tbaeder, tstellar, tuliom
Target Milestone: ---Keywords: FutureFeature, Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: llvm-17.0.3-1.fc39 Doc Type: ---
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2023-11-07 01:38:42 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Attachments:
Description Flags
Update to 17.0.3 (#2244592) none

Description Upstream Release Monitoring 2023-10-17 07:33:00 UTC
Releases retrieved: 17.0.3
Upstream release that is considered latest: 17.0.3
Current version/release in rawhide: 17.0.2-1.fc40
URL: http://llvm.org

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/1830/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/llvm

Comment 1 Upstream Release Monitoring 2023-10-17 07:33:07 UTC
Scratch build failed. Details below:

BuilderException: Build failed:
There is a syntax error in updated specfile. See attached diff for the changes.

Traceback:
  File "/usr/local/lib/python3.11/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.11/site-packages/hotness/builders/koji.py", line 205, in build
    raise BuilderException(str(exc), value=output)

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 2 Upstream Release Monitoring 2023-10-17 07:33:09 UTC
Created attachment 1994250 [details]
Update to 17.0.3 (#2244592)

Comment 3 Fedora Update System 2023-10-18 19:04:16 UTC
FEDORA-2023-35708fce92 has been submitted as an update to Fedora 40. https://bodhi.fedoraproject.org/updates/FEDORA-2023-35708fce92

Comment 4 Fedora Update System 2023-10-18 19:55:12 UTC
FEDORA-2023-35708fce92 has been pushed to the Fedora 40 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 5 Fedora Update System 2023-10-19 17:02:50 UTC
FEDORA-2023-f9ca9adf3e has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-f9ca9adf3e

Comment 6 Fedora Update System 2023-10-20 02:13:30 UTC
FEDORA-2023-f9ca9adf3e has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-f9ca9adf3e`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-f9ca9adf3e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2023-11-07 01:38:42 UTC
FEDORA-2023-f9ca9adf3e has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.