This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 224627

Summary: emacs 22: trademark issue with Tetris
Product: [Fedora] Fedora Reporter: Ville Skyttä <ville.skytta>
Component: emacsAssignee: Chip Coldwell <coldwell>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: dcantrell, hdegoede, mcepl, mwebbink, petersen, tcallawa, tromey
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 22.1-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-08-28 15:17:29 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 182235, 225726    
Attachments:
Description Flags
Screenshot of Emacs' Tools/Games menu none

Description Ville Skyttä 2007-01-26 14:11:28 EST
emacs 22.0.93-4 in devel includes Tetris and calls it by that name, which I
gather is a trademark problem.  Earlier Fedora/Red Hat packages of Emacs and
XEmacs have pruned it from the distributed packages for this reason.
Comment 1 Chip Coldwell 2007-01-26 14:27:01 EST
see bug 66237.
Comment 2 Ville Skyttä 2007-01-26 14:28:19 EST
Bugzilla won't let me: "You are not authorized to access bug #66237."
Comment 3 Chip Coldwell 2007-01-26 14:31:35 EST
Opened by Alan Cox (alan@redhat.com)  	 on 2002-06-06 13:24 EST

I thought we didnt ship Tetris games because of the stupid Tetris people. One
seems to have leaked back in ?
Comment 4 Tom "spot" Callaway 2007-01-26 14:46:53 EST
This is a rather obvious violation of a well protected trademark, held by a
notoriously litigious company. It needs to be taken out, yesterday.
Comment 5 Chip Coldwell 2007-01-26 14:53:08 EST
(In reply to comment #4)
> This is a rather obvious violation of a well protected trademark, held by a
> notoriously litigious company. It needs to be taken out, yesterday.

Oh, I am taking it out as we speak.  However, somebody (Spot? Me?) should make
this same point to FSF.

Chip
Comment 6 Chip Coldwell 2007-02-01 13:34:35 EST
From: 	Richard Stallman
Subject: 	Re: Tetris trademark
Date: 	Fri, 26 Jan 2007 23:19:13 -0500

    Is anybody concerned that lisp/play/tetris.el might be a trademark
    infringement?

File names and function names usually do not raise a trademark issue.
So there is no need to worry about this.



Comment 7 Chip Coldwell 2007-02-01 13:35:19 EST
(In reply to comment #6)
> From: 	Richard Stallman
> Subject: 	Re: Tetris trademark
> Date: 	Fri, 26 Jan 2007 23:19:13 -0500
> 
>     Is anybody concerned that lisp/play/tetris.el might be a trademark
>     infringement?
> 
> File names and function names usually do not raise a trademark issue.
> So there is no need to worry about this.

http://lists.gnu.org/archive/html/emacs-devel/2007-01/msg00916.html

> 
> 
> 

Comment 8 Ville Skyttä 2007-02-01 13:43:59 EST
It is not only file and function names, the game identifies itself very clearly
as "Tetris".

Menu entry: Tools -> Games -> Tetris
Window title when playing the game
Comment 9 Chip Coldwell 2007-02-01 14:06:34 EST
(In reply to comment #8)
> It is not only file and function names, the game identifies itself very clearly
> as "Tetris".
> 
> Menu entry: Tools -> Games -> Tetris
> Window title when playing the game

Read the whole thread:

Re: Tetris trademark
From: 	Richard Stallman
Subject: 	Re: Tetris trademark
Date: 	Sun, 28 Jan 2007 02:41:28 -0500

    But what about the game itself?  It's not just the name of the file
    and functions, but the Tetris game itself is "subject to the
    registered copyrights of Tetris Holding LLC" (according to
    http://www.tetris.com/).

My understanding is that game rules as such are not copyrightable.

I'll contact our legal dept and verify RMS's interpretation, but my guess is
that he gets it from Eben Moglen.

Chip
Comment 10 Ville Skyttä 2007-02-01 14:14:26 EST
I read the thread and it seems to me nobody's paying attention to the
observations in comment 8.  People talk about file and function names as well as
game rules, not the fact that the game identifies itself to end users as
"Tetris", which is the problematic bit as far as I can tell.
Comment 11 Chip Coldwell 2007-02-01 14:16:03 EST
According to circulars available from the United States Library of Congress, a
game cannot be copyrighted (only patented), which would invalidate much of TTC's
copyright claim on the game,[5] leaving the trademark on Tetris as TTC's most
significant claim on any government-granted monopoly.

http://en.wikipedia.org/wiki/Tetris#History
Comment 12 Chip Coldwell 2007-02-01 14:24:42 EST
(In reply to comment #10)
> I read the thread and it seems to me nobody's paying attention to the
> observations in comment 8.  People talk about file and function names as well as
> game rules, not the fact that the game identifies itself to end users as
> "Tetris", which is the problematic bit as far as I can tell.

IANAL (but I have contacted somebody who is), but I think the issue here is that
if you ship a text editor that contains a function called "tetris" defined in a
file called "tetris.el[c]", that is not a trademark violation.  If you were to
ship a script that ran

#!/bin/bash

exec emacs -f tetris

and named that script "tetris", then that would be a trademark violation.  It's
a fine distinction, but the law is made up of such fine distinctions.

Chip
Comment 13 Ville Skyttä 2007-02-01 14:44:20 EST
(In reply to comment #12)
> If you were to ship a script that ran
> #!/bin/bash
> exec emacs -f tetris
> and named that script "tetris", then that would be a trademark violation.

FWIW, I agree, and this is pretty much the same case as a menu entry in Emacs
called "Tetris" which launches the game (which in addition calls itself "Tetris"
when launched).
Comment 14 Tom "spot" Callaway 2007-02-01 15:59:07 EST
It's rather simple:

This application is a game. It calls itself Tetris when it runs. The owner of
the Tetris trademark didn't give permission. This is in violation of the Tetris
trademark.

"TTC's legal counsel sent cease and desist letters to web sites that misused the
Tetris trademark to refer to homemade tetromino games."

They obviously think it is a trademark violation, so nuke it. Unless Red Hat
Legal disagrees with my assessment, nuke it.
Comment 15 Chip Coldwell 2007-02-01 16:12:01 EST
(In reply to comment #14)

> 
> They obviously think it is a trademark violation,

True, but TTC's legal opinions have been wrong many times in the past. 

> Unless Red Hat Legal disagrees with my assessment, nuke it.

Red Hat Legal (in the persona of Mark Webbink) both agrees and disagrees with
you.    First, he agrees with you:

"We should not be shipping a game (even embedded in other software) that
promotes a game branded as Tetris for a game that resembles the TETRIS� game."

Then he agress with RMS:

"On the other hand, having a file with that name on it is no more a trademark
infringement than use of a Linux file that incorporates the term
redhat in the file name is an infringement of Red Hat's trademark,
even if that file executes a game that resembles the official TETRIS
game."

That last sentence isn't quite grammatical, but I think what Mark is saying is
that shipping tetris.el[c] is not a trademark infringement "even if that file
executes a game that resembles the official TETRIS game."

I've asked Mark for clarification of the apparent contradiction contained in his
response but haven't received it yet.

Chip

Comment 16 Chip Coldwell 2007-02-01 16:31:12 EST
Mark's clarification:

From mwebbink@redhat.com Thu Feb  1 16:27:28 2007
Date: Thu, 01 Feb 2007 16:27:26 -0500
From: Mark Webbink <mwebbink@redhat.com>
To: Chip Coldwell <coldwell@redhat.com>
Subject: Re: [Bug 224627] emacs 22: trademark issue with Tetris (fwd)

    [ The following text is in the "UTF-8" character set. ]

    [ Your display is set for the "ISO-8859-1" character set.  ]

    [ Some characters may be displayed incorrectly. ]

Chip,

My apologies for my lack of clarity.  Let me try again.

In our EULA for RHEL we tell users who want to redistribute the code
that they must remove the Red Hat logos and images from a couple of
files and replace them with their own logos and images.  We do this
because if they didn't change the files a person receiving the code
from them would believe that Red Hat, not the other person is the
source of that code (trademarks are a source identifier) when the
marks showed up in splash screens, etc.  What we don't insist that
they do is rename any file names that include redhat in the file name
extension because such use does not constitute trademark use.  In
fact most people wouldn't even be aware of the file names.

Applying this same criteria to emacs.  If emacs was promoted as
'EMACS with TETRIS," that is clearly a trademark use.  On the other
hand, if the emacs code merely has a file that has tetris
incorporated into its name, that's not a trademark violation.  If
that file is an executable and it brings up a TETRIS-like game that
has the TETRIS mark prominantly displayed with the game, its likely
to be trademark use.
Comment 17 Chip Coldwell 2007-02-01 16:33:46 EST
(In reply to comment #16)
> Mark's clarification:
> 
> If
> that file is an executable and it brings up a TETRIS-like game that
> has the TETRIS mark prominantly displayed with the game, its likely
> to be trademark use.

"... likely to be trademark use."  Always count on a lawyer for an incomplete
answer.

Anyway, if you've looked in cvs/emacs/devel recently, you'll see that version
22.0.93-5 does not contains tetris in the binary and hasn't since Jan 26.  The
source rpm, since it contains a tarball from FSF, will contain it.

Chip



Comment 18 Tom "spot" Callaway 2007-02-01 16:35:57 EST
It needs to come out of the source rpm too... either we can ship it, or we
can't, no halfsies. Just pull it out, note that the tarball has been modified
and use that as the Source.
Comment 19 Matěj Cepl 2007-03-06 17:28:04 EST
(In reply to comment #16)
> Applying this same criteria to emacs.  If emacs was promoted as
> 'EMACS with TETRIS," that is clearly a trademark use.  On the other
> hand, if the emacs code merely has a file that has tetris
> incorporated into its name, that's not a trademark violation.  If
> that file is an executable and it brings up a TETRIS-like game that
> has the TETRIS mark prominantly displayed with the game, its likely
> to be trademark use.

I used to be a lawyer doing IP stuff in the Czech republic, but I have been out
of legal business for couple of years, so this shouldn't be taken as legal
advice by any means (IP is notoriously complicated especially in the
international context).

So, I think Mark should be put as Cc: on this bug (which I am doing right now),
and he should be asked to comment specifically about the attached screenshot of
Emacs menu. It seems to me that this bug (and not only that -- the referred
email discussion is just the same) is whole one big comedy of mistakes -- we are
not talking about filenames (which are non-issue), and we are not talking about
outright advertising ("Emacs with Tetris"). But what about menu Tools/Games/Tetris?
Comment 20 Matěj Cepl 2007-03-06 17:30:22 EST
Created attachment 149395 [details]
Screenshot of Emacs' Tools/Games menu
Comment 21 Ville Skyttä 2007-03-06 17:50:53 EST
Also in case it matters, note that in the screenshot, while Tetris is running,
the Emacs window title shows *Tetris*
Comment 22 Chip Coldwell 2007-03-06 18:01:18 EST
*Sigh*  If I understand the history correctly, the companies that did all the
barratry over the Tetris trademark never actually owned the rights:

"In 1996 when Russian restrictions expired, he [Alexey Pajitnov who wrote the
game originally] and Henk Rogers formed The Tetris Company LLC and Blue Planet
Software in an effort to get royalties from the Tetris brand, with good success
on game consoles but very little on the PC front."

Prior claims of ownership were made by at least five companies: Atari, Nintendo,
Andromeda, Elorg and Spectrum Holobyte.  I think it's fair to say that the
probability of someone successfully protecting a Tetris trademark in court is
pretty slim.

But IANAL, and tetris.el is out of the rpm.

Chip

Comment 23 Tom "spot" Callaway 2007-03-06 18:15:12 EST
Not to be a broken record, but is it out of the SRPM too?
Comment 24 Tom "spot" Callaway 2007-03-06 18:25:14 EST
And, FWIW, the Tetris trademark has been rather well established as belonging to
Tetris Holding LLC since 1996, and that organization is the one who has been the
most aggressive at protecting the trademark to date.

The BBC Documentary on the history of Tetris is a fascinating overview. :)
Comment 25 Chip Coldwell 2007-03-06 18:30:31 EST
http://www.atarihq.com/tsr/special/tetrishist.html
Comment 26 Chip Coldwell 2007-03-06 18:32:50 EST
(In reply to comment #24)
> And, FWIW, the Tetris trademark has been rather well established as belonging to
> Tetris Holding LLC since 1996, and that organization is the one who has been the
> most aggressive at protecting the trademark to date.

Presumably the same Tetris Company LLC mentioned in comment #22 as having very
little success enforcing their trademark on PC versions (BTW, that quote comes
from the Wikipedia "Tetris" article).

Chip
Comment 27 Chip Coldwell 2007-03-06 18:34:20 EST
This company had a moment of fame in the late 90s when they tried to get every
freeware and shareware version of Tetris off the market by sending out
cease-and-desist letters. It's widely believed that the company has no valid
legal basis to claim rights to any tetromino game that does not infringe on the
Tetris name trademark, since copyright "look-and-feel" suits have not stood up
in court in the past (Lotus v. Borland), and the company apparently holds no
patents related to Tetris.

http://en.wikipedia.org/wiki/Tetris_Company
Comment 28 Tom "spot" Callaway 2007-03-06 18:40:20 EST
I'm not arguing they don't have any shred of a case on look-and-feel. But they
do have a solid case on trademark (and have been successful in protecting it to
date). That tetris.el file is clearly violating their Trademark. It need to be
pulled out of the source. If it always called itself "blockpuzzle", we wouldn't
be having this discussion.

Also, I'm not sure that Wikipedia is a valid citation source. :)
Comment 29 Tom "spot" Callaway 2007-03-07 11:03:25 EST
I've tried to condense my thoughts on this, and I know Mark is on the CC here,
so I hope he can correct anything for which he disagrees:

This issue is entirely around the trademark "Tetris". The tetris.el file meets
the criteria described by Mark Webbink:

"If that file is an executable and it brings up a TETRIS-like game that
has the TETRIS mark prominantly displayed with the game, its likely
to be trademark use."

I would go so far as to say that this is definitely trademark use. The tetris.el
file, when executed by Emacs, calls itself "Tetris" in the title bar. In the
emacs menu to launch this program, it calls itself "Tetris".

The "Tetris" trademark is registered by Tetris Holding LLC. This company is
aggressive in protecting improper use of its trademark. Emacs does not have
documented permission to use the Tetris trademark. Thus, the use in tetris.el is
improper.

It is not a case of fair-use, as we have a game which is calling itself TETRIS. 

Fedora (and Red Hat) are committed to respecting trademarks. We would be very
unhappy if someone wrote a piece of software which called itself "Fedora" or
"Red Hat Linux", because these are our trademarks. If someone wrote a
text-editor software which called itself "EMACS" when it ran, they would be
abusing the FSF's trademark. Accordingly, it is equally abusive to have a
falling block game call itself "TETRIS" when it runs, and this is not acceptable
for Fedora.

If you agree that this is not acceptable for Fedora, then we need to not ship
any files which abuse the "Tetris" trademark. Fedora ships two sets of packages,
binary and source rpms. We cannot abuse the trademark in either set of packages.

There are several options on how to resolve this issue:

1. Have upstream remove the trademark from tetris.el, so that it no longer calls
itself "Tetris" when it runs, and is not called "Tetris" in the menu item.
Strictly speaking, the file name can remain tetris.el, as that is not considered
trademark. When this is done, we have no pending trademark issues.

2. We make a modified tarball, which takes the tetris.el file, and alters it
such that it no longer calls itself "Tetris" when it runs, and is not called
"Tetris" in the menu item. It is unfortunately not sufficient to simply patch
these items out. Look at xmms and mp3 for precedence, we could not simply patch
out the questionable code for mp3 playback, we had to never ship it at all. This
is the same case, in my non-lawyer opinion.

3. We make a modified tarball, which does not include the tetris.el file at all,
and thus, avoids the trademark issues.

4. We don't ship emacs.

Unfortunately, the current state of emacs is such that the Tetris trademark is
only removed from the binary package, and not the source package. Since we
cannot ship the binary without the source package, this is not a workable case.

Please review what I've written, and consider one of the above solutions to
resolve this important legal issue. We cannot expect others to respect our
trademarks if we are not willing to respect the trademarks of others.
Comment 30 Jesse Keating 2007-03-07 11:13:52 EST
I tend to agree with Tom's wrapup, and as the release engineer for Fedora, I
feel that this needs to be resolved, before the next test release, or else I'll
have to go with option number 4 until it is resolved.
Comment 31 Chip Coldwell 2007-03-07 11:36:33 EST
(In reply to comment #29)

> 
> The tetris.el file meets the criteria described by Mark Webbink:
> 
> "If that file is an executable and it brings up a TETRIS-like game that
> has the TETRIS mark prominantly displayed with the game, its likely
> to be trademark use."

The tetris.el file in the source tarball is not an executable.

> If someone wrote a
> text-editor software which called itself "EMACS" when it ran, they would be
> abusing the FSF's trademark.

I don't believe the FSF (or anyone for that matter) holds a trademark on "emacs".

Chip
Comment 32 Jesse Keating 2007-03-07 11:41:55 EST
(In reply to comment #31)
> (In reply to comment #29)
> 
> > 
> > The tetris.el file meets the criteria described by Mark Webbink:
> > 
> > "If that file is an executable and it brings up a TETRIS-like game that
> > has the TETRIS mark prominantly displayed with the game, its likely
> > to be trademark use."
> 
> The tetris.el file in the source tarball is not an executable.
> 
> > If someone wrote a
> > text-editor software which called itself "EMACS" when it ran, they would be
> > abusing the FSF's trademark.
> 
> I don't believe the FSF (or anyone for that matter) holds a trademark on "emacs".
> 
> Chip
> 


While these are interesting data points, they don't do anything to resolve this
issue.  So the .el file isn't executable, you can still execute it or
compile/execute it.
Comment 33 Chip Coldwell 2007-03-07 11:50:09 EST
(In reply to comment #32)
> (In reply to comment #31)
> > (In reply to comment #29)
> > 
> > > 
> > > The tetris.el file meets the criteria described by Mark Webbink:
> > > 
> > > "If that file is an executable and it brings up a TETRIS-like game that
> > > has the TETRIS mark prominantly displayed with the game, its likely
> > > to be trademark use."
> > 
> > The tetris.el file in the source tarball is not an executable.
> > 
> > > If someone wrote a
> > > text-editor software which called itself "EMACS" when it ran, they would be
> > > abusing the FSF's trademark.
> > 
> > I don't believe the FSF (or anyone for that matter) holds a trademark on
"emacs".
> > 
> > Chip
> > 
> 
> 
> While these are interesting data points, they don't do anything to resolve this
> issue.

On the contrary.  The statement from Mark Webbink (who *is* a lawyer), starts
with "If that file is an executable ...".  Therefore, tetris.el in the source
tarball does not meet his criteria for "likely to be trademark use."  That was
my point.

Chip

Comment 34 Jesse Keating 2007-03-07 15:25:38 EST
> On the contrary.  The statement from Mark Webbink (who *is* a lawyer), starts
> with "If that file is an executable ...".  Therefore, tetris.el in the source
> tarball does not meet his criteria for "likely to be trademark use."  That was
> my point.
> 
> Chip
> 
> 

So what steps would it take to run the tetris.el(c) file included in the source
within emacs?  IE how does one get from the .el(c) file to playing the game?
Comment 35 Chip Coldwell 2007-03-07 16:03:10 EST
(In reply to comment #34)
>
> 
> So what steps would it take to run the tetris.el(c) file included in the source
> within emacs?  IE how does one get from the .el(c) file to playing the game?

$ rpm2cpio emacs-22.0.95-1.fc7.src.rpm | cpio -iv emacs-22.0.95.tar.gz
emacs-22.0.95.tar.gz
74549 blocks
[coldwell@dhcp83-29 tmp]$ tar xfz emacs-22.0.95.tar.gz
emacs-22.0.95/lisp/play/tetris.el
[coldwell@dhcp83-29 tmp]$ emacs -l emacs-22.0.95/lisp/play/tetris.el -f tetris

Comment 36 Jesse Keating 2007-03-07 16:09:12 EST
So while the file itself is not executable, it is easily executed by the
interpreter, emacs.  That's like saying a bash script isn't executable or a
python script isn't, but you can do python foo.py.  I think that for purposes of
trademark violation this tetris file _is_ executable, or close enough to it that
I don't want to take the chance.  Please pull it out of the source, and/or
convince upstream to do the same or rename it.
Comment 37 Tom "spot" Callaway 2007-03-07 16:21:06 EST
(In reply to comment #36)
> Please pull it out of the source, and/or convince upstream to do the same or 
> rename it.

Actually, renaming the file isn't going to do it. Removing the Tetris trademark
is the key.
Comment 38 Chip Coldwell 2007-03-07 16:23:49 EST
(In reply to comment #36)
> So while the file itself is not executable, it is easily executed by the
> interpreter, emacs.  That's like saying a bash script isn't executable or a
> python script isn't, but you can do python foo.py.  I think that for purposes of
> trademark violation this tetris file _is_ executable, or close enough to it that
> I don't want to take the chance.  Please pull it out of the source, and/or
> convince upstream to do the same or rename it.

You're coming late to this (old, tired) thread, so I'll bring you up to speed on
the relevant legal issues.

Neither a file name nor a function name can be trademarked.  So renaming the
file isn't going to matter.

I have brought up the topic upstream and they aren't worried, see comment #6
through comment #9.  I am not going to waste my time trying to convince them of
something that I am not convinced of myself, although I would encourage those
parties to this bug who are convinced to go ahead and try.  RMS is notoriously
stubborn, and notoriously sensitive to intellectual property issues.

Finally, I think this thing has been blown *way* out of proportion.  Do you know
what a trademark owner must do when he discovers you are using his trademark? 
He must send you a cease-and-desist letter.  If you then cease-and-desist using
it, the matter is over.

We now have seven people following this bug, all of whom have better things to
do with their time.  For example, there are still real bugs in emacs.

I'll pull tetris from the source tarball in my next update.  But I really feel
this whole thing is collosally stupid -- on a par with bug 171910.

Chip
Comment 39 Tom Tromey 2007-04-28 16:12:25 EDT
If menu-bar-mode is enabled (the default) you can still see a mention
of Tetris on the Tools->Games menu.
There are also a few mentions of it in the Emacs info documentation.
Comment 40 Hans de Goede 2007-05-01 10:44:44 EDT
I got pointed to this bug by a current thread about tetris on f-devel-l. As
someone who maintains many games. Let me put in my 2 cents here:

1) All user visible use of the word tetris must be removed, from the menu,
   titlebar, but also the docs. Once thats done, the game may be shipped
   (call it falling blocks game or what ever).

2) There is no need to remove any stuff from the srpm / upstream's tarbal. 
   IANAL but to infringe upon a trademark, you must "advertise" with it, iow
   show it to the intended users. Anyways gnome-games had the same problem and 
   has been vetted by legal, there legal decided that it was enough to not
   compile and ship the game, but it is still in the source tarbal. Whats good 
   enough for gnome-games, should be good enough for emacs. Other games in FE
   have followed the example of gnome games. For example crack-attack mentions
   tetris in the pristine docs several times, yet crack-attack is still using
   a pristine upstream tarbal. But the docs shipped in the binary rpm have been
   patched (see crack-attack-1.1.14-sanitize.patch).

   Thus AFAIK there is no problem with the TM being used in the srpm, as long
   as it isn't used in any user visible way in the binary rpm.

   If someone (legal) decides that the srpm's must be sanitized too, then this
   should be done for _all_ packages with potential trademark issues, which have
   solved this sofar with a patch / sed script. This includes, but is not 
   limited to:
   gnome-games
   crack-attack *
   emacs
   xgalaxy (name + logo + docs changed from xgalaga to xgalaxy) *
   pipenightdreams *
   * == maintained by me
Comment 41 Tom "spot" Callaway 2007-05-01 10:48:16 EDT
Thanks Hans. I think thats enough Fedora precedent and RH legal opinion to
convince me that we don't need a modified tarball in this case.

It should be sufficient to have all of the "Tetris" trademark items
removed/replaced.
Comment 42 Jonathan Underwood 2007-05-06 16:38:38 EDT
I asked the upstream developers once more about this issue, pointing out that
the trademark issues didn't apply to just the file and function names:

http://lists.gnu.org/archive/html/emacs-devel/2007-05/msg00016.html

RMS reported in a later thread that "I found out that we need not do anything
regarding tetris." See here:

http://lists.gnu.org/archive/html/emacs-devel/2007-05/msg00158.html

So, in short, it appears that upstream has investigated the issue with the FSF
legal people who concluded that there is no problem.

It is a shame that none of the upstream developers joined the discussion here or
reported what the FSF legal people actually said.
Comment 43 Tom "spot" Callaway 2007-05-06 19:30:40 EDT
Welp. The FSF may feel safe in violating the Tetris trademark, but Fedora sure
isn't feeling safe in violating it. 
Comment 44 Chip Coldwell 2007-11-19 12:55:49 EST
The latest upstream contains a link on the splash screen to

http://www.gnu.org/software/emacs/tour/

which specifically mentions "tetris", by name.  Apparently the FSF is really not
worried.
Comment 45 Tom "spot" Callaway 2007-11-19 13:04:23 EST
While I'm glad that the FSF doesn't take trademark infringement seriously,
Fedora does.