Bug 226055

Summary: Merge Review: libvirt
Product: [Fedora] Fedora Reporter: Nobody's working on this, feel free to take it <nobody>
Component: Package ReviewAssignee: Richard W.M. Jones <rjones>
Status: CLOSED RAWHIDE QA Contact: Fedora Package Reviews List <fedora-package-review>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: bashton, berrange, rjones, veillard, virt-maint
Target Milestone: ---Flags: rjones: fedora‑review+
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-02-12 07:37:37 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Nobody's working on this, feel free to take it 2007-01-31 14:28:31 EST
Fedora Merge Review: libvirt

http://cvs.fedora.redhat.com/viewcvs/devel/libvirt/
Initial Owner: veillard@redhat.com
Comment 1 Richard W.M. Jones 2009-02-11 07:36:23 EST
Taking for review.
Comment 2 Richard W.M. Jones 2009-02-11 08:04:05 EST
libvirt.src:143: W: unversioned-explicit-obsoletes libvir
libvirt.src:160: W: unversioned-explicit-obsoletes libvir-devel
libvirt.src:171: W: unversioned-explicit-obsoletes libvir-python
libvirt.src:534: W: macro-in-%changelog fedora
libvirt.src:719: W: macro-in-%changelog dist
libvirt.x86_64: E: non-standard-dir-perm /var/lib/libvirt/images 0700
libvirt.x86_64: E: non-standard-dir-perm /var/log/libvirt 0700
libvirt.x86_64: E: non-standard-dir-perm /var/lib/libvirt/qemu 0700
libvirt.x86_64: E: non-standard-dir-perm /etc/libvirt 0700
libvirt.x86_64: E: non-standard-dir-perm /var/lib/libvirt/uml 0700
libvirt.x86_64: E: non-standard-dir-perm /var/lib/libvirt/lxc 0700
libvirt.x86_64: E: non-standard-dir-perm /etc/libvirt/qemu 0700
libvirt.x86_64: W: file-not-utf8 /usr/share/doc/libvirt-0.6.0/NEWS
libvirt.x86_64: E: incoherent-logrotate-file /etc/logrotate.d/libvirtd
libvirt.x86_64: E: non-standard-dir-perm /var/lib/libvirt/iptables/filter 0700
libvirt.x86_64: E: non-standard-dir-perm /etc/libvirt/qemu/networks 0700
libvirt.x86_64: E: non-standard-dir-perm /var/lib/libvirt/boot 0700
libvirt.x86_64: E: executable-marked-as-config-file /etc/sysconfig/libvirtd
libvirt.x86_64: E: script-without-shebang /etc/sysconfig/libvirtd
libvirt.x86_64: E: non-standard-dir-perm /var/lib/libvirt/network 0700
libvirt.x86_64: E: non-standard-dir-perm /var/log/libvirt/qemu 0700
libvirt.x86_64: E: non-standard-dir-perm /etc/libvirt/qemu/networks/autostart 0700
libvirt.x86_64: E: non-standard-dir-perm /var/lib/libvirt/iptables/nat 0700
libvirt.x86_64: E: non-standard-dir-perm /var/lib/libvirt/iptables 0700
libvirt.x86_64: E: explicit-lib-dependency libxml2
libvirt.x86_64: W: obsolete-not-provided libvir
libvirt.x86_64: W: dangerous-command-in-%post ln
libvirt.x86_64: W: one-line-command-in-%postun /sbin/ldconfig
libvirt.x86_64: W: service-default-enabled /etc/rc.d/init.d/libvirtd
libvirt.x86_64: W: service-default-enabled /etc/rc.d/init.d/libvirtd
libvirt-devel.x86_64: W: spurious-executable-perm /usr/share/doc/libvirt-devel-0.6.0/examples/python/domstart.py
libvirt-devel.x86_64: W: spurious-executable-perm /usr/share/doc/libvirt-devel-0.6.0/examples/index.py
libvirt-devel.x86_64: W: spurious-executable-perm /usr/share/doc/libvirt-devel-0.6.0/examples/python/domrestore.py
libvirt-devel.x86_64: W: spurious-executable-perm /usr/share/doc/libvirt-devel-0.6.0/examples/python/domsave.py
libvirt-devel.x86_64: W: spurious-executable-perm /usr/share/doc/libvirt-devel-0.6.0/examples/python/dominfo.py
libvirt-devel.x86_64: W: obsolete-not-provided libvir-devel
libvirt-devel.x86_64: W: doc-file-dependency /usr/share/doc/libvirt-devel-0.6.0/examples/index.py /usr/bin/python
libvirt-devel.x86_64: W: doc-file-dependency /usr/share/doc/libvirt-devel-0.6.0/examples/python/dominfo.py /usr/bin/python
libvirt-devel.x86_64: W: doc-file-dependency /usr/share/doc/libvirt-devel-0.6.0/examples/python/domrestore.py /usr/bin/python
libvirt-devel.x86_64: W: doc-file-dependency /usr/share/doc/libvirt-devel-0.6.0/examples/python/domsave.py /usr/bin/python
libvirt-devel.x86_64: W: doc-file-dependency /usr/share/doc/libvirt-devel-0.6.0/examples/python/domstart.py /usr/bin/python
libvirt-python.x86_64: W: spurious-executable-perm /usr/share/doc/libvirt-python-0.6.0/python/dominfo.py
libvirt-python.x86_64: W: file-not-utf8 /usr/share/doc/libvirt-python-0.6.0/NEWS
libvirt-python.x86_64: E: non-executable-script /usr/lib64/python2.5/site-packages/libvirt.py 0644
libvirt-python.x86_64: W: spurious-executable-perm /usr/share/doc/libvirt-python-0.6.0/python/domsave.py
libvirt-python.x86_64: W: spurious-executable-perm /usr/share/doc/libvirt-python-0.6.0/error.py
libvirt-python.x86_64: W: spurious-executable-perm /usr/share/doc/libvirt-python-0.6.0/uuid.py
libvirt-python.x86_64: W: spurious-executable-perm /usr/share/doc/libvirt-python-0.6.0/basic.py
libvirt-python.x86_64: W: spurious-executable-perm /usr/share/doc/libvirt-python-0.6.0/python/domstart.py
libvirt-python.x86_64: W: spurious-executable-perm /usr/share/doc/libvirt-python-0.6.0/node.py
libvirt-python.x86_64: W: spurious-executable-perm /usr/share/doc/libvirt-python-0.6.0/python/domrestore.py
libvirt-python.x86_64: W: spurious-executable-perm /usr/share/doc/libvirt-python-0.6.0/create.py
libvirt-python.x86_64: W: obsolete-not-provided libvir-python
libvirt-python.x86_64: W: doc-file-dependency /usr/share/doc/libvirt-python-0.6.0/basic.py /usr/bin/python
libvirt-python.x86_64: W: doc-file-dependency /usr/share/doc/libvirt-python-0.6.0/create.py /usr/bin/python
libvirt-python.x86_64: W: doc-file-dependency /usr/share/doc/libvirt-python-0.6.0/error.py /usr/bin/python
libvirt-python.x86_64: W: doc-file-dependency /usr/share/doc/libvirt-python-0.6.0/node.py /usr/bin/python
libvirt-python.x86_64: W: doc-file-dependency /usr/share/doc/libvirt-python-0.6.0/python/dominfo.py /usr/bin/python
libvirt-python.x86_64: W: doc-file-dependency /usr/share/doc/libvirt-python-0.6.0/python/domrestore.py /usr/bin/python
libvirt-python.x86_64: W: doc-file-dependency /usr/share/doc/libvirt-python-0.6.0/python/domsave.py /usr/bin/python
libvirt-python.x86_64: W: doc-file-dependency /usr/share/doc/libvirt-python-0.6.0/python/domstart.py /usr/bin/python
libvirt-python.x86_64: W: doc-file-dependency /usr/share/doc/libvirt-python-0.6.0/uuid.py /usr/bin/python
5 packages and 0 specfiles checked; 20 errors, 42 warnings.
Comment 3 Richard W.M. Jones 2009-02-11 12:23:11 EST
I've posted a patch upstream[1] which reduces the number
of rpmlint problems.  Now we are left with:

> libvirt.x86_64: E: non-standard-dir-perm /var/lib/libvirt/images 0700
> (for various directories)

I think rpmlint is wrong about these errors.  The permissions
on these directories is intended to be 0700.

> libvirt.x86_64: E: incoherent-logrotate-file /etc/logrotate.d/libvirtd

Rpmlint's complaint is the logrotate file should have the same
name as the package.  In this case it has the same name as the
daemon, which seems acceptable to me.

> libvirt.x86_64: W: dangerous-command-in-%post ln

It's a fair warning, but in this case the use of 'ln' in %post
is justified.

> libvirt-devel.x86_64: W: spurious-executable-perm /usr/share/doc/libvirt-devel-0.6.0/examples/python/domstart.py
> (and various other *.py files)

For the examples, this seems OK, since people may wish to run
the examples directly.

For the python libraries, there is a mix of +x/-x permissions, and
I don't know what is correct.

> libvirt-devel.x86_64: W: doc-file-dependency /usr/share/doc/libvirt-devel-0.6.0/examples/index.py /usr/bin/python
> (etc)

This seems OK to me.

[1] https://www.redhat.com/archives/libvir-list/2009-February/msg00211.html
Comment 4 Richard W.M. Jones 2009-02-11 12:30:52 EST
+ rpmlint output

See above.  Depends on the patch being acceptable upstream.

+ package name satisfies the packaging naming guidelines
+ specfile name matches the package base name
+ package should satisfy packaging guidelines
+ license meets guidelines and is acceptable to Fedora
+ license matches the actual package license
+ %doc includes license file
+ spec file written in American English
+ spec file is legible
+ upstream sources match sources in the srpm
+ package successfully builds on at least one architecture
n/a ExcludeArch bugs filed
+ BuildRequires list all build dependencies
+ %find_lang instead of %{_datadir}/locale/*
+ binary RPM with shared library files must call ldconfig in %post and %postun
+ does not use Prefix: /usr
+ package owns all directories it creates
+ no duplicate files in %files
+ %defattr line
+ %clean contains rm -rf $RPM_BUILD_ROOT
+ consistent use of macros
+ package must contain code or permissible content
n/a large documentation files should go in -doc subpackage
+ files marked %doc should not affect package
+ header files should be in -devel
n/a static libraries should be in -static
+ packages containing pkgconfig (.pc) files need 'Requires: pkgconfig'
+ libfoo.so must go in -devel
+ -devel must require the fully versioned base

  I changed: Requires: libvirt = %{version}-%{release}

+ packages should not contain libtool .la files
n/a packages containing GUI apps must include %{name}.desktop file
+ packages must not own files or directories owned by other packages
+ %install must start with rm -rf %{buildroot} etc.
+ filenames must be valid UTF-8

Optional:

n/a if there is no license file, packager should query upstream
n/a translations of description and summary for non-English languages, if available
+ reviewer should build the package in mock
+ the package should build into binary RPMs on all supported architectures
+ review should test the package functions as described
+ scriptlets should be sane
+ pkgconfig files should go in -devel
+ shouldn't have file dependencies outside /etc /bin /sbin /usr/bin or /usr/sbin
Comment 5 Richard W.M. Jones 2009-02-12 07:37:37 EST
I have agreed changes with upstream and added the patch
to Rawhide.

----------------------------------
This package is APPROVED by rjones
----------------------------------