Bug 2276339

Summary: [odf 4.15] In Replica-1 data always goes to one particular osd and never goes to the additional osds present for a failure domain
Product: [Red Hat Storage] Red Hat OpenShift Data Foundation Reporter: Malay Kumar parida <mparida>
Component: ocs-operatorAssignee: Malay Kumar parida <mparida>
Status: CLOSED WONTFIX QA Contact: Elad <ebenahar>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.15CC: apolak, kramdoss, nberry, odf-bz-bot
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: 2275222 Environment:
Last Closed: 2024-08-21 21:19:06 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 2275222    
Bug Blocks:    

Description Malay Kumar parida 2024-04-22 05:39:06 UTC
+++ This bug was initially created as a clone of Bug #2275222 +++

In Replica-1 we support increasing the number of osds per failure domain. But even after the number of osds per failure domain is increased the data always goes to one particular osd. This results in a large imbalance of data among the osds in a failure domain.

This happens because the PG & PGP number stays at 1 always for the replica-1 pools

pool 5 'ocs-storagecluster-cephblockpool-us-east-1b' replicated size 1 min_size 1 crush_rule 8 object_hash rjenkins pg_num 1 pgp_num 1 autoscale_mode on last_change 126 flags hashpspool,selfmanaged_snaps stripe_width 0 application rbd
pool 6 'ocs-storagecluster-cephblockpool-us-east-1c' replicated size 1 min_size 1 crush_rule 10 object_hash rjenkins pg_num 1 pgp_num 1 autoscale_mode on last_change 128 flags hashpspool,selfmanaged_snaps stripe_width 0 application rbd
pool 7 'ocs-storagecluster-cephblockpool-us-east-1a' replicated size 1 min_size 1 crush_rule 13 object_hash rjenkins pg_num 1 pgp_num 1 autoscale_mode on last_change 123 flags hashpspool,selfmanaged_snaps stripe_width 0 application rbd

Is there any workaround available to the best of your knowledge?
Yes, disable the reconciliation of cephblockpool and add 
spec:
  parameters:
    pg_num: '16'
    pgp_num: '16'

--- Additional comment from RHEL Program Management on 2024-04-16 05:55:17 UTC ---

This bug having no release flag set previously, is now set with release flag 'odf‑4.16.0' to '?', and so is being proposed to be fixed at the ODF 4.16.0 release. Note that the 3 Acks (pm_ack, devel_ack, qa_ack), if any previously set while release flag was missing, have now been reset since the Acks are to be set against a release flag.

--- Additional comment from RHEL Program Management on 2024-04-16 05:55:17 UTC ---

The 'Target Release' is not to be set manually at the Red Hat OpenShift Data Foundation product.

The 'Target Release' will be auto set appropriately, after the 3 Acks (pm,devel,qa) are set to "+" for a specific release flag and that release flag gets auto set to "+".

--- Additional comment from RHEL Program Management on 2024-04-18 08:22:33 UTC ---

This BZ is being approved for ODF 4.16.0 release, upon receipt of the 3 ACKs (PM,Devel,QA) for the release flag 'odf‑4.16.0

--- Additional comment from RHEL Program Management on 2024-04-18 08:22:33 UTC ---

Since this bug has been approved for ODF 4.16.0 release, through release flag 'odf-4.16.0+', the Target Release is being set to 'ODF 4.16.0

--- Additional comment from errata-xmlrpc on 2024-04-18 18:10:52 UTC ---

This bug has been added to advisory RHBA-2023:125619 by ceph-build service account (ceph-build.COM)

Comment 3 krishnaram Karthick 2024-05-02 11:32:14 UTC
Moving the bug to 4.15.4 as we have reached the limit on bugs intake for 4.15.3