Bug 229077

Summary: The package breaks an previous installation of the Fedora DS!!
Product: [Fedora] Fedora Reporter: Frank Büttner <bugzilla>
Component: 389-dsAssignee: Rich Megginson <rmeggins>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: medium    
Version: 6CC: aaron, dennis, nhosoi, rmeggins
Target Milestone: ---Keywords: screened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-04-03 14:57:41 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
diffs for configure.ac
none
cvs commit log
none
new spec file
none
cvs commit log none

Description Frank Büttner 2007-02-16 15:08:09 EST
Description of problem:
On an system, where the server is installed from
http://directory.fedora.redhat.com it will become complete unusable after run
yum update. Because first the files are not migrated and second the complete
java management tools are removed. This must be fixes so fast as possible.
Comment 1 Rich Megginson 2007-02-16 15:48:50 EST
The fedora-ds 1.1.0a1 in Fedora Extras is the core only - when you upgrade, you
remove all of the other files for admin server, console, etc.  The good news is
that none of the configuration or data is affected and you can easily recover by
following these steps:

* Find the fedora-ds 1.0.4 RPM you installed from originally, or download from
http://directory.fedora.redhat.com/wiki/Download
* rpm -Uvh --oldpackage fedora-ds-1.0.4-1......rpm

You should _not_ run setup after doing this.  We are working on a solution for
this.  We will hopefully figure out a way to install both 1.0.4 and 1.1 at the
same time, but we may have to make the 1.1 Conflicts: fedora-ds < 1.1 or
something like that.  In the meantime, fedora-ds is being pulled from the Fedora
Extras yum repos so that this doesn't happen again.
Comment 2 Frank Büttner 2007-02-16 15:54:19 EST
At now I have installed the one from http://directory.fedora.redhat.com and
server is working again:)
And what is with the java management tools? Or are they in an addition package?
Comment 3 Rich Megginson 2007-02-16 15:57:07 EST
(In reply to comment #2)
> At now I have installed the one from http://directory.fedora.redhat.com and
> server is working again:)

Good.  And again, I apologize.

> And what is with the java management tools? Or are they in an addition package?

The java console is included in fedora-ds-1.0.4 - we are unbundling them from
the core ds in 1.1 - see http://directory.fedora.redhat.com/wiki/Discrete_Packaging
Comment 4 Rich Megginson 2007-02-23 13:46:38 EST
Created attachment 148698 [details]
diffs for configure.ac
Comment 5 Rich Megginson 2007-02-23 14:28:13 EST
Revised diff - just bump version to 1.1.0a2 from 1.1.0a1.
Index: ldapserver/configure.ac
===================================================================
RCS file: /cvs/dirsec/ldapserver/configure.ac,v
retrieving revision 1.22
diff -u -2 -r1.22 configure.ac
--- ldapserver/configure.ac     22 Feb 2007 23:59:13 -0000      1.22
+++ ldapserver/configure.ac     23 Feb 2007 19:27:59 -0000
@@ -3,5 +3,5 @@
 AC_PREREQ(2.59)
 # This version is the version returned by ns-slapd -v
-AC_INIT([fedora-ds], [1.1.0a1], [http://bugzilla.redhat.com/])
+AC_INIT([fedora-ds], [1.1.0a2], [http://bugzilla.redhat.com/])
 # AC_CONFIG_HEADER must be called right after AC_INIT.
 AC_CONFIG_HEADERS([config.h])
Comment 6 Noriko Hosoi 2007-02-23 14:33:42 EST
Very nice.  We have less impacts... :)
Comment 7 Rich Megginson 2007-02-23 14:41:38 EST
Created attachment 148705 [details]
cvs commit log

Reviewed by: nhosoi, rcritten, dgilmore (Thanks!)
Files: configure.ac and all generated autotool files
Branch: HEAD
Fix Description: As it turns out, only the spec file will have to change.  It
is ok that we have a package named pkgname-base that uses paths like
/etc/pkgname and service pkgname.  So this diff has been revised to simply bump
the version in the code to differentiate it from the previously withdrawn
fedora-ds in Fedora Extras.
Platforms tested: RHEL4, FC6
Flag Day: No.
Doc impact: No.
Comment 8 Rich Megginson 2007-02-23 14:52:22 EST
Created attachment 148709 [details]
new spec file

This is the proposed new spec file.  The Name is now fedora-ds-base.  I have
introduced a macro called %{shortname} which expands to fedora-ds.  This is
used for all file, directory, and service naming so we can continue to use e.g.
/etc/fedora-ds instead of /etc/fedora-ds-base (/etc/%{name}).
Comment 9 Rich Megginson 2007-02-23 16:04:21 EST
Checking in .cvsignore;
/cvs/extras/rpms/fedora-ds-base/devel/.cvsignore,v  <--  .cvsignore
new revision: 1.3; previous revision: 1.2
done
RCS file: /cvs/extras/rpms/fedora-ds-base/devel/fedora-ds-base-cvs.sh,v
done
Checking in fedora-ds-base-cvs.sh;
/cvs/extras/rpms/fedora-ds-base/devel/fedora-ds-base-cvs.sh,v  <-- 
fedora-ds-base-cvs.sh
initial revision: 1.1
done
RCS file: /cvs/extras/rpms/fedora-ds-base/devel/fedora-ds-base-devel.README,v
done
Checking in fedora-ds-base-devel.README;
/cvs/extras/rpms/fedora-ds-base/devel/fedora-ds-base-devel.README,v  <-- 
fedora-ds-base-devel.README
initial revision: 1.1
done
RCS file: /cvs/extras/rpms/fedora-ds-base/devel/fedora-ds-base.spec,v
done
Checking in fedora-ds-base.spec;
/cvs/extras/rpms/fedora-ds-base/devel/fedora-ds-base.spec,v  <-- 
fedora-ds-base.spec
initial revision: 1.1
done
Removing fedora-ds-cvs.sh;
/cvs/extras/rpms/fedora-ds-base/devel/fedora-ds-cvs.sh,v  <--  fedora-ds-cvs.sh
new revision: delete; previous revision: 1.1
done
Removing fedora-ds-devel.README;
/cvs/extras/rpms/fedora-ds-base/devel/fedora-ds-devel.README,v  <-- 
fedora-ds-devel.README
new revision: delete; previous revision: 1.1
done
Removing fedora-ds.spec;
/cvs/extras/rpms/fedora-ds-base/devel/fedora-ds.spec,v  <--  fedora-ds.spec
new revision: delete; previous revision: 1.1
done
Checking in install.inf;
/cvs/extras/rpms/fedora-ds-base/devel/install.inf,v  <--  install.inf
new revision: 1.2; previous revision: 1.1
done
Checking in sources;
/cvs/extras/rpms/fedora-ds-base/devel/sources,v  <--  sources
new revision: 1.3; previous revision: 1.2
done
Comment 10 Rich Megginson 2007-02-23 16:18:53 EST
Created attachment 148722 [details]
cvs commit log

These are the commits for FC-5 and FC-6
Comment 11 Rich Megginson 2007-02-23 19:10:01 EST
fedora-ds-base was successfully built in fc5, fc6, and fc7