Bug 232370

Summary: Loading tifm_core should automatically load tifm_sd
Product: [Fedora] Fedora Reporter: Michel Alexandre Salim <michel.salim>
Component: udevAssignee: Jon Masters <jcm>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: dqarras, gauret, mikkel, mishu
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-08-27 02:03:54 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Michel Alexandre Salim 2007-03-14 21:13:33 EDT
Description of problem:
I have a Texas Instrument card reader (tifm_7xx1); currently it is detected
out-of-the-box, and some kernel modules (tifm_core and tifm_7xx1) loaded;
however, the third module, tifm_sd, is not. The kernel would thus detect card
insertions and removals, but would not create the device node needed for mounting

Version-Release number of selected component (if applicable):
module-init-tools-3.3-0.pre6.1.9.fc7


How reproducible:
Always

Steps to Reproduce:
1. Boot computer
2. Insert SD card
3. dmesg
  
Actual results:
Device insertion is reported, but no device is created in /dev

Expected results:
Device node should be created in /dev

Additional info:
Comment 1 Aurelien Bompard 2007-03-16 11:43:43 EDT
I confirm this, here is the relevant output of lspci:
02:06.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader
(SD/MMC/MS/MS PRO/xD)
02:06.3 Class 0805: Texas Instruments PCIxx12 SDA Standard Compliant SD Host
Controller

Versions:
kernel-2.6.20-1.2990.fc7
module-init-tools-3.3-0.pre6.1.9.fc7

Comment 2 Daniel Qarras 2007-06-27 14:28:33 EDT
This is the same or least related to

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=217070

which just got solved with a minor change to udev.
Comment 3 Jon Masters 2007-08-20 02:11:40 EDT
Is this still an issue? If so, let's get udev changed again.

Jon.
Comment 4 Mikkel L. Ellertson 2007-08-23 13:48:37 EDT
What I did is create a pair of udev rules to load and unload the tifm_sd rules
when a card is inserted or removed. I believe this is needed because there are
seperate modules that need to be loaded to match the type of card being
inserted. Because I only have SD cards, I can not check if my rules do a proper
check, but it should be possible to add udev rules that load/unload the correct
module with better matching then I have...

# SD card in tifm socket control.
BUS=="tifm", ACTION=="add", ID=="tifm_sd0:1", RUN+="modprobe tifm_sd"
BUS=="tifm", ACTION=="remove", ID=="tifm_sd0:1", RUN+="modprobe -r tifm_sd"

I do have one problem though - it is not getting automounted. But I think this
is a HAL problem...

[mikkel@toshiba ~]$ gnome-mount -v -b -d /dev/mmcblk0p1 -m music
gnome-mount 0.5
libhal-storage.c 1401 : INFO: called LIBHAL_FREE_DBUS_ERROR but dbusError was
not set.

** (gnome-mount:5585): WARNING **: Given device '/dev/mmcblk0p1' is not a volume
or a drive.
[mikkel@toshiba ~]$ ls -l /dev/mmc*
brw-r----- 1 root disk 179, 0 Aug 23 12:04 /dev/mmcblk0
brw-r----- 1 root disk 179, 1 Aug 23 12:04 /dev/mmcblk0p1

Comment 5 Daniel Qarras 2007-08-25 10:03:11 EDT
I suggest you to test with udev-113-11.fc7, it fixed Bug 217070 for me and my SD
card reader works now perfectly with F7!