Enable FIPS and start systemd-resolved service with the following error:
Jan 06 06:58:40 fedora audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-resolved comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
This issue only exists on openssl-3.2.2-10.fc41.x86_64, openssl-libs-3.2.2-10.fc41.x86_64.
openssl-3.2.2-9.fc41.x86_64, openssl-libs-3.2.2-9.fc41.x86_64 works well.
Reproducible: Always
Actual Results:
Can't start systemd-resolved service
Expected Results:
Start systemd-resolved without error
Log should be like Jan 06 06:58:40 fedora systemd-resolved[1127]: Failed to create SSL context: error:1C8000D6:Provider routines::module integrity failure
Comment 2Dmitry Belyavskiy
2025-01-07 08:25:06 UTC