Bug 235497

Summary: add_to_rules: unknown key 'ATTRS{idVendor}'
Product: [Fedora] Fedora Reporter: Martin West <martin>
Component: udevAssignee: Harald Hoyer <harald>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6CC: deerfieldtech
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-04-10 09:36:45 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Martin West 2007-04-06 06:42:44 EDT
Description of problem:

After a recent update these errors have been appearing at boot time ...

/var/log/messages:Apr  3 19:42:50 lenovo1 udevd[487]: add_to_rules: unknown key
'ATTRS{idVendor}'
/var/log/messages:Apr  3 19:42:50 lenovo1 udevd[487]: add_to_rules: unknown key
'ATTRS{idProduct}'
/var/log/messages:Apr  3 19:42:50 lenovo1 udevd[487]: add_to_rules: unknown key
'ATTRS{idVendor}'
/var/log/messages:Apr  3 19:42:50 lenovo1 udevd[487]: add_to_rules: unknown key
'ATTRS{idProduct}'
/var/log/messages:Apr  3 19:42:50 lenovo1 udevd[487]: add_to_rules: unknown key
'ATTRS{idVendor}'
...
Version-Release number of selected component (if applicable):

udev.i386                                095-17.fc6             installed

Linux lenovo1.thecla.com 2.6.20-1.2933.fc6 #1 SMP

How reproducible:

Install latest version of udev on a lenovo N100

Steps to Reproduce:
1.
  
Actual results:

see above

Expected results:

??
Additional info:
Comment 1 P Jones 2007-04-08 10:41:38 EDT
I'm getting a udevd[427] on an HPD530S (not with F7T3, for what that's worth).
Comment 2 Harald Hoyer 2007-04-10 04:34:09 EDT
Please provide the output of:
$ fgrep -rl 'ATTRS{idVendor}' /etc/udev/rules.d
and
$ rpm -qf $(fgrep -rl 'ATTRS{idVendor}' /etc/udev/rules.d)
Comment 3 P Jones 2007-04-10 08:03:59 EDT
This is from my laptop;

[root@pc-00246 ~]# fgrep -rl 'ATTRS{idVendor}' /etc/udev/rules.d
/etc/udev/rules.d/kino.rules
[root@pc-00246 ~]# rpm -qf $(fgrep -rl 'ATTRS{idVendor}' /etc/udev/rules.d)
kino-1.0.0-1.fc6

I get the same results on the D530S. I'm using Kino from FreshRPMS. On the F7T3
machines I have Kino installed but from Livna Devel.

Not a Fedora problem I guess?
Comment 4 Harald Hoyer 2007-04-10 09:36:45 EDT
yes... bug kino
Comment 5 Martin West 2007-04-10 13:48:03 EDT
K, beat me to it.  Thanks