Bug 235710

Summary: fwbackups: RFE: add exclusion paths
Product: [Fedora] Fedora Reporter: Bernard Johnson <bjohnson>
Component: fwbackupsAssignee: Stewart Adam <s.adam>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 6   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: fwbackups-1.43.0-0.1.rc3.fc6 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-06-21 03:58:41 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Bernard Johnson 2007-04-09 19:02:03 UTC
Description of problem:
Please add exclusion paths to the backup.  Both tar and rsync handle excludes. 
Here is a real world example:

I want to backup my /var/lib directories because they contain stateful
information, like my mysql databases.  However, I also use this system to build
for mock.  This currently uses 2.4G of space (cached build roots) - and since
they are cached, they are recreated whenever needed.

If I want to backup /var/lib/ and skip mock, I have to add:
+ /var/lib/a
+ /var/lib/b
+ /var/lib/c
+ /var/lib/d
etc

etc. to the backup set.

It would be much nicer to be able to add:
+ /var/lib
- /var/lib/mock

Version-Release number of selected component (if applicable):
fwbackups-1.43.0-0.1.beta2.fc6