Bug 2362265

Summary: netatalk fails to start on Fedora Server 42
Product: [Fedora] Fedora Reporter: Nigel Jewell <nigel.jewell>
Component: netatalkAssignee: Andrew Bauer <zonexpertconsulting>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 42CC: orion, ryan, zonexpertconsulting
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: ---
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2025-04-25 11:46:12 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Nigel Jewell 2025-04-25 08:01:49 UTC
Fresh install of Fedora 42 and netatalk fails to start.  I continue to get the following logged:

-- Boot 7abc10ed9dd94ecf96fffd6f73e775cf --
Apr 25 08:48:27 REMOVED systemd[1]: Starting netatalk.service - Netatalk AFP fileserver for Macintosh clients...
Apr 25 08:48:27 REMOVED systemd[1]: netatalk.service: Can't open PID file '/run/lock/netatalk/netatalk/netatalk' (yet?) after start: No such file or directory
Apr 25 08:48:27 REMOVED systemd[1]: netatalk.service: Failed with result 'protocol'.
Apr 25 08:48:27 REMOVED systemd[1]: Failed to start netatalk.service - Netatalk AFP fileserver for Macintosh clients.
Apr 25 08:48:29 REMOVED systemd[1]: netatalk.service: Scheduled restart job, restart counter is at 1.
Apr 25 08:48:29 REMOVED systemd[1]: Starting netatalk.service - Netatalk AFP fileserver for Macintosh clients...
Apr 25 08:48:29 REMOVED systemd[1]: netatalk.service: Can't open PID file '/run/lock/netatalk/netatalk/netatalk' (yet?) after start: No such file or directory
Apr 25 08:49:59 REMOVED systemd[1]: netatalk.service: start operation timed out. Terminating.
Apr 25 08:49:59 REMOVED systemd[1]: netatalk.service: Failed with result 'timeout'.
Apr 25 08:49:59 REMOVED systemd[1]: Failed to start netatalk.service - Netatalk AFP fileserver for Macintosh clients.
Apr 25 08:50:00 REMOVED systemd[1]: netatalk.service: Scheduled restart job, restart counter is at 2.
Apr 25 08:50:00 REMOVED systemd[1]: Starting netatalk.service - Netatalk AFP fileserver for Macintosh clients...
Apr 25 08:50:00 REMOVED systemd[1]: netatalk.service: Can't open PID file '/run/lock/netatalk/netatalk/netatalk' (yet?) after start: No such file or directory
Apr 25 08:51:30 REMOVED systemd[1]: netatalk.service: start operation timed out. Terminating.
Apr 25 08:51:30 REMOVED systemd[1]: netatalk.service: Failed with result 'timeout'.
Apr 25 08:51:30 REMOVED systemd[1]: Failed to start netatalk.service - Netatalk AFP fileserver for Macintosh clients.
Apr 25 08:51:32 REMOVED systemd[1]: netatalk.service: Scheduled restart job, restart counter is at 3.
Apr 25 08:51:32 REMOVED systemd[1]: Starting netatalk.service - Netatalk AFP fileserver for Macintosh clients...
Apr 25 08:51:32 REMOVED systemd[1]: netatalk.service: Can't open PID file '/run/lock/netatalk/netatalk/netatalk' (yet?) after start: No such file or directory
Apr 25 08:53:02 REMOVED systemd[1]: netatalk.service: start operation timed out. Terminating.
Apr 25 08:53:02 REMOVED systemd[1]: netatalk.service: Failed with result 'timeout'.
Apr 25 08:53:02 REMOVED systemd[1]: Failed to start netatalk.service - Netatalk AFP fileserver for Macintosh clients.
Apr 25 08:53:03 REMOVED systemd[1]: netatalk.service: Scheduled restart job, restart counter is at 4.
Apr 25 08:53:03 REMOVED systemd[1]: Starting netatalk.service - Netatalk AFP fileserver for Macintosh clients...
Apr 25 08:53:03 REMOVED systemd[1]: netatalk.service: Can't open PID file '/run/lock/netatalk/netatalk/netatalk' (yet?) after start: No such file or directory
Apr 25 08:54:33 REMOVED systemd[1]: netatalk.service: start operation timed out. Terminating.
Apr 25 08:54:33 REMOVED systemd[1]: netatalk.service: Failed with result 'timeout'.
Apr 25 08:54:33 REMOVED systemd[1]: Failed to start netatalk.service - Netatalk AFP fileserver for Macintosh clients.
Apr 25 08:54:35 REMOVED systemd[1]: netatalk.service: Scheduled restart job, restart counter is at 5.
Apr 25 08:54:35 REMOVED systemd[1]: Starting netatalk.service - Netatalk AFP fileserver for Macintosh clients...
Apr 25 08:54:35 REMOVED systemd[1]: netatalk.service: Can't open PID file '/run/lock/netatalk/netatalk/netatalk' (yet?) after start: No such file or directory
Apr 25 08:56:05 REMOVED systemd[1]: netatalk.service: start operation timed out. Terminating.
Apr 25 08:56:05 REMOVED systemd[1]: netatalk.service: Failed with result 'timeout'.
Apr 25 08:56:05 REMOVED systemd[1]: Failed to start netatalk.service - Netatalk AFP fileserver for Macintosh clients.
Apr 25 08:56:06 REMOVED systemd[1]: netatalk.service: Scheduled restart job, restart counter is at 6.
Apr 25 08:56:06 REMOVED systemd[1]: Starting netatalk.service - Netatalk AFP fileserver for Macintosh clients...
Apr 25 08:56:06 REMOVED systemd[1]: netatalk.service: Can't open PID file '/run/lock/netatalk/netatalk/netatalk' (yet?) after start: No such file or directory
Apr 25 08:57:36 REMOVED systemd[1]: netatalk.service: start operation timed out. Terminating.
Apr 25 08:57:36 REMOVED systemd[1]: netatalk.service: Failed with result 'timeout'.
Apr 25 08:57:36 REMOVED systemd[1]: Failed to start netatalk.service - Netatalk AFP fileserver for Macintosh clients.
Apr 25 08:57:38 REMOVED systemd[1]: netatalk.service: Scheduled restart job, restart counter is at 7.
Apr 25 08:57:38 REMOVED systemd[1]: Starting netatalk.service - Netatalk AFP fileserver for Macintosh clients...
Apr 25 08:57:38 REMOVED systemd[1]: netatalk.service: Can't open PID file '/run/lock/netatalk/netatalk/netatalk' (yet?) after start: No such file or directory
...

Reproducible: Always

Steps to Reproduce:
1. install netatalk
2. enable service
3. start service
Actual Results:
Fails to start as logged.

Expected Results:
The service should start out of the box.

Comment 1 Andrew Bauer 2025-04-25 11:46:12 UTC
Duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=2360947

*** This bug has been marked as a duplicate of bug 2360947 ***

Comment 2 Nigel Jewell 2025-04-25 12:05:23 UTC
Thanks Andrew.  I did search for this but missed it.

Comment 3 Andrew Bauer 2025-04-25 12:09:34 UTC
Understood. It's easy to miss, as the package update process auto-closes the effected bugs even though the package is not yet pushed to stable repos.

I'm building yet another netatalk package soon as well. Upstream broke our ability to build the html doc subpackage. I expect that to be fixed in the next release after this one.