Bug 237958

Summary: Wrong init script
Product: Red Hat Enterprise Linux 5 Reporter: Michal Marciniszyn <mmarcini>
Component: cyrus-imapdAssignee: Tomas Janousek <tjanouse>
Status: CLOSED DEFERRED QA Contact: Brian Brock <bbrock>
Severity: low Docs Contact:
Priority: low    
Version: 5.0CC: tvujec
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-06-05 20:29:19 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 237789, 237964, 237965    

Description Michal Marciniszyn 2007-04-26 11:50:07 UTC
Description of problem:
There are several errors in the script, for example
[ ${NETWORKING} = "no" ] && exit 0
exits with error code 0 when no networking is present even though the service is
not running. Similar constructions and some wrong error codes can be found
through the script.

Version-Release number of selected component (if applicable):
all

How reproducible:
always

Steps to Reproduce:
1. service network stop
2. service cyrus-imapd start/status
3. echo $?
  
Actual results:
0

Expected results:
non-zero error code/status of the service

Additional info:
When fixing this bug, please obbey our init script guidelines and be sure that
status command is run correctly.
Our guidelines are on following two pages:
http://intranet.corp.redhat.com/ic/intranet/InitscriptsSpec.html
http://intranet.corp.redhat.com/ic/intranet/InitscriptGuidelines.html

For an example of the script that returns the error codes correctly and always
runs status see:
http://devserv.devel.redhat.com/~mmarcini/amd

This bug is tracked by 237789.

Comment 1 RHEL Product and Program Management 2007-06-05 20:29:19 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Since this
bugzilla is in a component that is not approved for the current
release, it has been closed with resolution deferred.  You may
reopen this bugzilla for consideration in the next release.