Bug 238762

Summary: Support "auto" for "Import cache size" in the LDBM Plug-in Settings
Product: [Retired] 389 Reporter: Noriko Hosoi <nhosoi>
Component: UI - ConfigurationAssignee: Rich Megginson <rmeggins>
Status: CLOSED CURRENTRELEASE QA Contact: Chandrasekar Kannan <ckannan>
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0.4CC: benl, dlackey, jgalipea, rmeggins
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 8.1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-04-29 23:00:12 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 152373, 234969, 249650, 493682    
Attachments:
Description Flags
auto cache on window
none
auto cache off window
none
diffs
none
cvs commit log none

Description Noriko Hosoi 2007-05-02 20:22:54 UTC
Description of problem:
Directory Console | Configuration | Database Settings | LDBM Plug-in Settings
Import cache size shows 20000000 bytes by default and no item for the Import
cache autosize.  On the other hand, the database configuration sets 
  nsslapd-import-cache-autosize: -1
by default, which means the import cache autosizing is enabled and it sets 50%
of free physical memory.  The real server configuration is not reflected to the
Console UI.  Also, even if a customer changes the value on Console, it does not
change the import cache size since autosizing is enabled and has a higher priority.

Proposal: if import-cache-autosize is on (-1 or some positive value), the
Console Import cache size displays "auto".  If the value is changed by a user,
the value is assigned to nsslapd-import-cachesize and
nsslapd-import-cache-autosize is disabled (by setting 0).

If this is easy, if "auto" is the value of Import cache size, it'd be nice to
have another ratio box to store the percentage of autosizing.  But I don't think
it's that necessary. We experienced that setting higher number (> 60%), cache
autosizing tests often failed due to the lack of memory.  So, we don't want
customers to set high number.  Instead, we'd like them to stay with 50% (-1). 
That's said, hiding the ratio might be preferable.

I've added "By default, ..." sentence to the Admin Guide, Tuning Directory
Server Performance chapter as follows.
> In the Import Cache Size field, enter a value corresponding to the amount of
memory in bytes that you want to make available for import.  By default, the
value is “auto” and 50% of the free memory is allocated for the import cache. 
If you are creating a very large database from LDIF, set this attribute as large
as possible, depending on the memory available on your machine. The larger this
parameter, the faster your database will be created.

Comment 2 Deon Ballard 2008-02-15 21:43:44 UTC
Changing dependencies; these guides were never targets for 8.0 and shouldn't be
blocking the 8.0 tracker.

Comment 3 Rich Megginson 2008-12-12 03:00:06 UTC
Created attachment 326699 [details]
auto cache on window

Comment 4 Rich Megginson 2008-12-12 03:00:32 UTC
Created attachment 326700 [details]
auto cache off window

Comment 5 Rich Megginson 2008-12-12 03:07:28 UTC
Created attachment 326701 [details]
diffs

Comment 6 Rich Megginson 2008-12-12 18:36:01 UTC
Created attachment 326755 [details]
cvs commit log

Reviewed by: nhosoi (Thanks!)
Fix Description: Added a check box for "use auto cache size".  If this is checked, a value of -1 will be saved for nsslapd-import-cache-autosize which will tell the server to use the default auto cache value.  If this is not checked, a value of 0 will be saved which will tell the server to use the number from nsslapd-import-cachesize.  If the check box is checked, the import cachesize field will be disabled.  Here are a couple of screen shots.
https://bugzilla.redhat.com/attachment.cgi?id=326699
https://bugzilla.redhat.com/attachment.cgi?id=326700
Platforms tested: RHEL5
Flag Day: no
Doc impact: yes - will have to document the new UI

Comment 7 Jenny Severance 2009-03-30 19:56:24 UTC
verified DS 8.1 RHEL 5

When checked:
nsslapd-import-cache-autosize: -1

When unchecked:
nsslapd-import-cache-autosize: 0

Comment 8 Chandrasekar Kannan 2009-04-29 23:00:12 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0455.html