Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.

Bug 239913

Summary: 30-aliases-fedora.conf should be split
Product: [Fedora] Fedora Reporter: Nicolas Mailhot <nicolas.mailhot>
Component: fontconfigAssignee: Behdad Esfahbod <behdad>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: triage
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: bzcl34nup
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-04-15 12:53:44 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 438944    

Description Nicolas Mailhot 2007-05-12 06:15:10 EDT
30-aliases-fedora.conf should be split so new font packages declaring
helvetica/arial... aliases can be added in Fedora without requiring changes in
the main fontconfig package
Comment 1 Behdad Esfahbod 2007-05-12 14:17:03 EDT
Yep.  This is a bit hard though.  I'll give it a shot in a few weeks after F7 is
out.
Comment 2 Behdad Esfahbod 2007-05-14 07:56:20 EDT
The cost of this btw is that fontconfig has to read more files at startup.
Comment 3 Nicolas Mailhot 2007-05-14 08:14:54 EDT
However, for fonts Fedora ship in their own package, you can move the relevant
files in the font package itself, so the average Fedora desktop (which does not
have every possible font package installed) will have less fontconfig rules to
process overall.

But sure, it's a balancing act and flexibility has a cost.
Comment 4 Behdad Esfahbod 2007-10-29 17:33:53 EDT
Note however that not all parts of font-specific stuff can go into font
packages.  When a user asks for font A and you don't have it installed, you want
to know whether you should substitute a sans or sans-serif (or monospace fwiw)
for it.  That means, some installed configuration should talk about font A.

I'm inclined to just clean up the current fedora confs and send them for
upstream fontconfig inclusion.
Comment 5 Nicolas Mailhot 2007-10-29 17:46:49 EDT
I was not suggesting to remove arial aliasing if arial is not on-system, I was
suggesting to move rules that say replace A with B to B package as they're
useless if B is not on-system
Comment 6 Bug Zapper 2008-04-03 20:39:43 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 7 Nicolas Mailhot 2008-04-04 02:48:29 EDT
IMHO that's up to Behdad to decide how we move on from now. We've progressed
quite a bit since the bug was opened, but we could do more if there is a will to
Comment 8 Jon Stanley 2008-04-05 15:00:11 EDT
Behdad -

What do you want to do from here?  Moving this to F10Target for now, feel free
to remove if not going to happen
Comment 9 Behdad Esfahbod 2008-04-15 12:53:44 EDT
That file has been moved to upstream in fontconfig 2.5.  And no, it can't be
easily split.