Bug 242073

Summary: Network mounts deleted from /etc/fstab
Product: [Fedora] Fedora Reporter: Roy Stogner <roystgnr>
Component: anacondaAssignee: Chris Lumens <clumens>
Status: CLOSED RAWHIDE QA Contact:
Severity: high Docs Contact:
Priority: low    
Version: 7CC: joachim.backes, k.georgiou
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-06-07 17:03:08 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Roy Stogner 2007-06-01 11:28:51 EDT
Description of problem:

After an upgrade from Fedora Core 6 to 7, lines corresponding to network mounted
drives were missing from /etc/fstab; e.g.:

files:/files/u0         /files/u0               nfs    
rw,hard,intr,rsize=32768,wsize=32768     0 0

was deleted.

How reproducible:

Unknown.  The workstation in question has a PATA hard drive and so presumably
had to have /etc/fstab rewritten to change "hda" to "sda" on filesystem and swap
partitions.  I'll be doing future upgrades on machines with SATA and SCSI drives
as well; if the results differ I'll reply to this bug.
Comment 1 Roy Stogner 2007-06-01 23:23:43 EDT
Even on SATA-based workstations where partition names already began with
/dev/sd, my /etc/fstab files are being rewritten; the only change in those cases
is that all NFS entries are removed.
Comment 2 Jérôme Benoit 2007-06-06 17:04:09 EDT
Same thing here with NFS mount point ... 

Anaconda a little bit too zealous ;-)
Comment 3 Chris Lumens 2007-06-07 17:03:08 EDT
This bug is now addressed by an updates image.  It is available for download at:


Instructions for using updates disks are located at:


If possible, please test this image out and report if it fixes your issue or
not.  Once we are confident that your issue is solved by this image, we are
going to announce it more publicly.  This fix may also be included in an updated
anaconda package later for people who are making custom Fedora distributions. 
Thanks for your time.
Comment 4 Roy Stogner 2007-06-20 16:31:55 EDT
The updates image works correctly on every computer I've tried.
Comment 5 Chris Lumens 2007-07-11 10:03:09 EDT
*** Bug 247763 has been marked as a duplicate of this bug. ***