Bug 243811

Summary: XError on right click menus in OOo.
Product: [Fedora] Fedora Reporter: Jonathan Kamens <jik>
Component: cairoAssignee: Behdad Esfahbod <behdad>
Status: CLOSED ERRATA QA Contact:
Severity: urgent Docs Contact:
Priority: urgent    
Version: 7CC: ajsfedora, atu, behdad, caolanm, cmaynard, corbet, cworth, darrellpf, kmaraas, marek78uk, matthias, mishu, paul, sangu.fedora
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-06-28 15:49:46 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
Ignore XErrors during deferred destruction
none
Avoid deferring resource cleanup for application drawables
none
Avoid deferring resource cleanup for application drawables
none
Avoid deferring resource cleanup for application drawables none

Description Jonathan Kamens 2007-06-11 21:50:15 EDT
Run ooffice.
Open a new spreadsheet.
Right click on a column header and select Delete Columns.
Note how ooffice exits.

I have 2.2.1-18.1.fc8.
Comment 1 Caolan McNamara 2007-06-12 03:27:20 EDT
There seems to be an XError being generated somewhere, 

Try and use export SAL_IGNOREXERRORS=YES before launching calc from a terminal
and see if that works around it for now.
Comment 2 Jonathan Kamens 2007-06-12 07:08:43 EDT
Yes, that does seem to suppress the issue.
Comment 3 Caolan McNamara 2007-06-12 07:16:43 EDT
So there's some XError causing this, I need to track it down. 

More than likely something else in the dependency tree has changed triggering
this, might not be an OOo bug, or it may be an old OOo bug recently uncovered.

Playing around it seems to be something around right clicking to get popup menus
Comment 4 Caolan McNamara 2007-06-13 09:02:31 EDT
X-Error: RenderBadPicture (invalid Picture parameter)
        Major opcode: 154
        Minor opcode: 7
        Resource ID:  0x3800597
        Serial No:    9507 (9507)
Comment 5 Caolan McNamara 2007-06-13 09:44:36 EDT
caolanm->ajackson: The F-7 OOo rpms don't show this on F-7, but do if installed
on rawhide. Any quick ideas so what may have changed ?
Comment 6 Adam Jackson 2007-06-14 12:10:38 EDT
There's basically zero difference between F7 and rawhide X at this point.

What hardware is this with?
Comment 7 Caolan McNamara 2007-06-14 14:21:21 EDT
I have it with nv on "nVidia GeForce4 Ti 4200 Go AGP 8x" and "nVidia GeForce
6800 GS"
Comment 8 Chris Maynard 2007-06-14 23:09:02 EDT
I see the same issue here with fc7 updates-testing and fc7, fc7 updates, and fc8
openoffice rpms. A crash happens every few times I right click on a column or
row, but every time I delete a cell with the delete key (regardless of "Delete
All" or any option.), or delete a column or row.

The export seems to fix the problem. 

Video card is an Intel 915GM.

Is there any any other debugging info I can provide?
Comment 9 Caolan McNamara 2007-06-15 05:11:48 EDT
*** Bug 244354 has been marked as a duplicate of this bug. ***
Comment 10 Caolan McNamara 2007-06-15 05:16:46 EDT
damn it. This certainly wasn't happening during f-7 development,

Marek Matulka: what's your X driver ? 
Comment 11 markm 2007-06-15 05:41:20 EDT
My video card is Nvidia Quadro NVS 110M (GPU 0)

I am using latest nvidia drivers provided by freshprms.net repository and at
first I thought the problem is in nvidia update to a new 100.x line of drivers,
but it's not. I have checked also 'nv' driver and I have exactly the same
behavior - OpenOffice crashes after several clicks (usually right click and any
click is enough).

The export trick works for me fine, but it's not handy :)
Comment 12 Caolan McNamara 2007-06-15 06:27:22 EDT
right, versions of cairo please ? 
The F-7 release was "cairo-1.4.4-1.fc7", what do the F-7 reporters of this have
installed ?
Comment 13 markm 2007-06-15 06:37:47 EDT
I have a cairo-1.4.8-1.fc7 from Fedora 7 Test Updates
Comment 14 Caolan McNamara 2007-06-15 06:52:37 EDT
yeah, ok. Do the obvious and roll-back just cairo to the F-7 version. I believe
that this crash has been triggered that single updated package
Comment 15 markm 2007-06-15 07:25:07 EDT
yep :) it solved a problem, with cairo 1.4.4 works fine and doesn't crash on
double clicks :)
Thanks for a quick help!
Comment 16 Caolan McNamara 2007-06-15 07:31:51 EDT
oky doky, even if this is an OOo problem we shouldn't push a cairo update for
F-7 which breaks it. I'll try and track down what changed in cairo to cause
this. And then maybe we can see who's broken.

caolanm->behdad: Hold on the cairo F-7 update, unless you want an angry mob with
pitchforks :-)
Comment 17 Caolan McNamara 2007-06-15 09:42:24 EDT
git diff 8ad30ccdb0a00701b15003edb2fe0cd4a8a9dfb7
88c6d25d4e53ddad6f3d465b2f5249c76a421b82

apparently triggers it
Comment 18 Chris Wilson 2007-06-15 16:09:24 EDT
Created attachment 157155 [details]
Ignore XErrors during deferred destruction

It is possible for the application to destroy the Drawable associated with a
Picture before cairo has the chance to process the deferred work queue - this
causes an XError when we later attempt to call XRenderFreePicture.
Comment 19 Caolan McNamara 2007-06-18 10:54:11 EDT
*** Bug 244642 has been marked as a duplicate of this bug. ***
Comment 20 Matthias Saou 2007-06-20 03:40:20 EDT
*** Bug 244964 has been marked as a duplicate of this bug. ***
Comment 21 Caolan McNamara 2007-06-21 13:47:42 EDT
*** Bug 245204 has been marked as a duplicate of this bug. ***
Comment 22 Caolan McNamara 2007-06-21 13:49:25 EDT
I'm plagued by this, can we at least push a replacement testing update ?
Comment 23 Behdad Esfahbod 2007-06-21 15:39:09 EDT
The current fix has serious performance penalties.  We are working on a better
fix upstream.  I unpushed the update for now.
Comment 24 Caolan McNamara 2007-06-21 16:51:40 EDT
*** Bug 245235 has been marked as a duplicate of this bug. ***
Comment 25 Caolan McNamara 2007-06-25 03:37:55 EDT
*** Bug 245464 has been marked as a duplicate of this bug. ***
Comment 26 Chris Wilson 2007-06-26 13:03:12 EDT
Created attachment 157916 [details]
Avoid deferring resource cleanup for application drawables

An alternative approach that avoids the requirement for XSyncs. Patch relative
to cairo-1.4.8.
Comment 27 Chris Wilson 2007-06-26 15:54:02 EDT
Created attachment 157947 [details]
Avoid deferring resource cleanup for application drawables

An alternative approach that avoids the requirement for XSyncs. Patch relative
to cairo-1.4.8.
Comment 28 Caolan McNamara 2007-06-27 07:35:50 EDT
*** Bug 245910 has been marked as a duplicate of this bug. ***
Comment 29 Carl Worth 2007-06-28 15:49:46 EDT
I tested Chris's fix and verified that it makes the OpenOffice.org crash go
away. His fix is included in the recent cairo 1.4.10 release.

New packages have been built for both F-7 and devel ("rawhide"), so should be
appearing soon.

I personally apologize for any lost data, and for the delay in getting a new
package out to resolve this problem.

But thanks to everyone running these bleeding-edge packages and reporting bugs!

-Carl