Bug 244493

Summary: f7 kickstart installs extended dhcp sessions then stage2.img fetch failure
Product: [Fedora] Fedora Reporter: John McBride <skunkworx>
Component: anacondaAssignee: Dave Cantrell <dcantrell>
Status: CLOSED DUPLICATE QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: 7CC: bugzilla, emcnabb, gasi, jmccann, netllama, peter, ron
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-08-16 21:13:39 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Attachments:
Description Flags
dell 1425 smolt. Loops DHCP on KS and installation fails. DVD install is fine. none

Description John McBride 2007-06-16 04:37:02 UTC
Description of problem:

On most of my servers F7 kickstart installs fail if the network device is set to
DHCP in the ks.cfg.

The symptom is :

1) eth0 interface dhcp's
2) the grab of the KS file over the network happens
3) then a rash of dhcp traffic on the same interface (eth0) again, takes a minute
4) then a popup asking for the server/path.

Saying "okay" (as the server/path are actually valid) results in a failure along
the lines of "retrieval of stage2.img failed".

The KS was taken from a DVD install of F7 and the written KS has the dhcp line.

Seems to affect servers with multiple intel gb. ether. These servers have been
fine until now (from around fc2) with kickstart installs.

Using a static IP in the ks network definition then cleaning up the sysconfig in
% post is my workaround for now. 

Version-Release number of selected component (if applicable):


How reproducible:
Seems to affect dual interface dell servers.

Steps to Reproduce:
1. Install via ks http method with network device dhcp'ing
2. Watch console dhcp and fetch ks file via eth0
3. Watch console loop dhcp on same interface, then eventually fail to fetch
stage2.img
  
Actual results:
No install unless static ip is used.

Expected results:
Install of F7

Additional info:
Can provide smolt files or possibly ks logs with some guidance. When this
happens, there is no command shell yet (I don't think).

Comment 1 Herbert Gasiorowski 2007-06-18 08:16:21 UTC
Me too ...

I assume having the same fault on a single ethernet card pc:
  Core 2 Duo E6600, 965G Chipset
It fetches the kickstart file using dhcp without problems, but then it tries
dhcp again (from ks "network" section) and it fails (5 times).
The requests seem to reach the dhcp server.


Comment 2 Lonni J Friedman 2007-06-19 15:50:19 UTC
Add me to the list.  I threw an Intel Gigabit PCI NIC into a random system, and
tripped across this bug as well.

Comment 3 John McBride 2007-06-23 06:04:20 UTC
Created attachment 157675 [details]
dell 1425 smolt. Loops DHCP on KS and installation fails. DVD install is fine.

This smolt is from a server with the DHCP problem.

Comment 4 Peter McNabb 2007-06-26 03:37:16 UTC
I am also experiencing this problem with an Intel 82566 DM (Gigabit) nic. It uses the e1000 driver. It's the 
only network card in the system.

Comment 5 Phil Oester 2007-06-27 17:55:57 UTC
Looks like a duplicate of bug 241783

Comment 6 Dave Cantrell 2007-08-16 21:13:39 UTC
DHCP kickstart installs are working fine in rawhide, so I'm thinking this is
hardware related.  Dup'ing against bug 241783.

*** This bug has been marked as a duplicate of 241783 ***