Bug 244964

Summary: OpenOffice.Org calc crash on copy/paste
Product: [Fedora] Fedora Reporter: Matthias Saou <matthias>
Component: openoffice.orgAssignee: Caolan McNamara <caolanm>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 7   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-06-20 03:40:16 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Matthias Saou 2007-06-20 03:01:54 EDT
On a computer running an i386 install of F7, upgraded with yum from FC6, oocalc
is closing all by itself after some operations, usually pasting into a cell
which already had some content (and having clicked OK to overwrite it), then
simply hitting an arrow key to move to the next cell... *poof*. Opening the file
again prompts for its recovery.

Using gdb (but I'm no debugging expert, especially not with all those threads!),
the last line I get when oocalc closes is :

Program exited with code 0116.

Searching Google for this error message, I came across this thread :
http://lists.linuxcoding.com/rhl/2007q2/msg09778.html

Which seems to indicate that other users have a similar problem.

Notes :
- I tried removing ~/.openoffice.org2.0 but same thing
- I tried switching from es_ES.UTF-8 to en_US.UTF-8 but same thing
- The entire system is F7 current as of now (has updates-testing too)
- No core dump. No useful strace logs. Threads, I guess.
- I tried disabling compiz (using it with the free radeon driver), same thing

There is nothing else fancy or otherwise weird on this computer. Please let me
know if there are any steps I can do to try and provide more useful information.
Comment 1 Matthias Saou 2007-06-20 03:26:32 EDT
I just tried removing the extra langpacks I had (fr,de,es,ca_ES), same thing.
Then I realized two things :
- I did not have openoffice.org-base installed. I added it, but same thing.
- I tried yum groupinstall "Office/Productivity" which installed
  openoffice.org-langpack-en, but same thing.

With the ods documents I have, the problem is 100% reproducible, so I just tried
with a new document, launching oocalc from the GNOME panel, and it's present
too! Steps :
- Launch oocalc
- Type "test" in cell A-1, press enter
- Type "test" again, in cell A-2, press enter
- Move up to A-2, copy with Ctrl+C
- Move up to A-1, paste with Ctrl+V, answer "Yes" to the warning
- Move down, ooo closes.

Now the fun bit : If you unfocus oocacl, like coming to this firefox page then
back to oocalc, before doing the last step (move to another cell after
overwriting it), ooo will not close! HTH.
Comment 2 Caolan McNamara 2007-06-20 03:28:52 EDT
This sounds like an XError, What is your version of cairo ? if it is "1.4.8"
from "testing updates", then revert to the last stable "1.4.4", if that works
then this is a duplicate of bug 243811
Comment 3 Matthias Saou 2007-06-20 03:40:16 EDT
Bingo! I guess having ooo say it's an X error (as planned in bug #243904) will
be nice too. Thanks a lot for the quick answer, some workers here will be less
frustrated today ;-)

*** This bug has been marked as a duplicate of 243811 ***