Bug 245416

Summary: db4 nptl-abi-note fails to assemble on arm, still needed?
Product: [Fedora] Fedora Reporter: Lennert Buytenhek <buytenh>
Component: db4Assignee: Jindrich Novy <jnovy>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhideCC: pknirsch
Target Milestone: ---   
Target Release: ---   
Hardware: arm9   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-03-10 07:51:55 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 245418    

Description Lennert Buytenhek 2007-06-22 18:07:04 EDT
db4 includes nptl-abi-note.S, which is meant to ensure that we are running on at
least a 2.4.20 kernel.

Unfortunately, this file doesn't assemble on ARM, as it contains a line
'.section .note.GNU-stack, "", @progbits', where '@' denotes the start of a
comment in ARM assembler.  (On ARM, you'd use '%progbits'.)

I would include a patch to exclude building the nptl note on ARM systems, but
considering that the current Fedora glibc causes /sbin/init to bomb out on boot
if you're running on anything older than 2.6.9, do we really still need
nptl-abi-note in this day and age?

Thanks for your time.
Comment 1 Jindrich Novy 2007-07-31 10:11:50 EDT
Agreed. I think we can safely remove it from the devel db4.

Thanks for pointing this out.
Comment 2 Lennert Buytenhek 2008-03-10 07:51:55 EDT
This has been fixed since db4 4.6.18-1.