Bug 245514

Summary: Recent Yum Update Broke Wifi
Product: [Fedora] Fedora Reporter: Johnny Proton <obijuan>
Component: dhcpAssignee: David Cantrell <dcantrell>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 7   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://forums.fedoraforum.org/showthread.php?p=817067
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-07-16 12:05:54 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Johnny Proton 2007-06-24 15:28:19 EDT
I rebooted my laptop on Friday the 22nd and found that wireless no longer works
at all? I see there are a lot of dhcp related updates that happened on the 21st
and 22nd but I was wondering if anyone else was experiencing this problem?

    Jun 21 08:17:58 Updated: gtk2.i386 2.10.13-1.fc7
    Jun 21 08:17:59 Updated: xorg-x11-drv-i810.i386 2.0.0-4.fc7
    Jun 21 08:18:02 Updated: pykickstart.noarch 1.1.1-1.fc7
    Jun 21 08:18:02 Updated: libdhcp4client.i386 12:3.0.5-36.fc7
    Jun 21 08:18:03 Updated: xorg-x11-drv-ati.i386 6.6.3-4.fc7
    Jun 21 08:18:04 Updated: dhclient.i386 12:3.0.5-36.fc7
    Jun 22 16:25:31 Updated: esound-libs.i386 1:0.2.38-2.fc7
    Jun 22 16:25:32 Updated: bind-libs.i386 31:9.4.1-6.1.fc7
    Jun 22 16:25:35 Updated: usermode.i386 1.92-0.fc7
    Jun 22 16:25:54 Updated: sampler.i386 1.5.1-1
    Jun 22 16:25:54 Updated: esound.i386 1:0.2.38-2.fc7
    Jun 22 16:25:55 Updated: usermode-gtk.i386 1.92-0.fc7
    Jun 22 16:25:56 Updated: bind-utils.i386 31:9.4.1-6.1.fc7
    Jun 22 16:25:58 Updated: kudzu.i386 1.2.71.1-1


I originally thought this was a problem with iwl3945 (which was working fine for
me) so I blacklisted it and instead went with ipw3945 but that didn't solve the
problem.
Comment 1 Christopher Aillon 2007-06-25 16:28:51 EDT
If NM worked before your update, and yuo updated, and NM hasn't changed, chances
are it isn't NM....
Comment 2 David Cantrell 2007-06-25 16:39:46 EDT
Not much changed in dhcp.  Added a patch from the OLPC project (running that
locally, wireless works).  I also changed some of output formatting in the init
scripts.

Can you downgrade to the dhcp package(s) that came with the original F-7 release
and see if those restore functionality?
Comment 3 Johnny Proton 2007-06-26 00:52:32 EDT
I don't even know how to do that... I know that I am unable to connect to any
wireless network at this point, and I'm using an Intel 3945 chipset and iwlwifi.
 It was working flawlessly before this update though.

It seems that this problem only corresponds to this chipset in particular, as
other developers in my company don't have this issue.

What should I do?
Comment 4 David Cantrell 2007-06-26 10:12:50 EDT
What I meant was downgrade your dhcp packages to the ones that were released
with Fedora 7 as the ones you picked up via the Fedora 7 Updates collection have
broken network connectivity on your system.

To do that, go to this URL:

http://download.fedora.redhat.com/pub/fedora/linux/releases/7/Fedora/i386/os/Fedora/

Download the following packages:

dhclient-3.0.5-35.fc7.i386.rpm
libdhcp4client-3.0.5-35.fc7.i386.rpm

Then run rpm and force the downgrade (by default, rpm logic selects the most
recent version of a package, so if you try to install these and already have an
update installed, it will say what you have installed is more recent than what
you are trying to install.  Since you want to downgrade, you have to force the
operation in rpm):

rpm -Uvh --force dhclient-3.0.5-35.fc7.i386.rpm libdhcp4client-3.0.5-35.fc7.i386.rpm

Any missing dependency errors you get, go and download the other rpms you need
from the URL above.  After downgrading the dhcp components, reboot, and try
connecting to the network again.

But, since you say that no one else are your work is having this problem using
the same versions of the software you are using, I'm inclined to regard this as
a kernel bug.  I am going to reassign it to the kernel component, but you should
try the downgraded versions of the dhcp components as well.
Comment 5 Johnny Proton 2007-06-26 22:42:08 EDT
That fixed it!

The reason no one else at my work was having the problem is because I'm the only
person using F7 *and* the Intel 3945 card.  Looks like the problem is with both
ipw3945 and iwl3945 because both of them wouldn't work.

Does this give you anything you need?  Would love to be part of the fix for this
because I was feeling a ton of Fedora pain this past couple days and I'd love to
help others out with it.
Comment 6 David Cantrell 2007-07-16 11:52:44 EDT
Does the current dhcp packages available for Fedora 7 exhibit the same problems?
 The latest available build in the F-7 updates is 3.0.5-38.fc7.  You originally
reported the problem with build 36 (3.0.5-36.fc7), so I'm wondering if the
problem is still there with build 38.  Let me know.
Comment 7 Johnny Proton 2007-07-16 12:05:54 EDT
As it turns out, this was probably something on my end.  It turns out that the
iwlwifi package is just having a hard time connecting to certain encrypted
wireless networks.  I think this bug would be better off if it was just closed.