Bug 246755

Summary: Xen guest unusable for compilation
Product: [Fedora] Fedora Reporter: Kai Engert (:kaie) (on vacation) <kengert>
Component: xenAssignee: Xen Maintainance List <xen-maint>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 7CC: triage, xen-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-06-16 21:47:18 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Kai Engert (:kaie) (on vacation) 2007-07-04 12:30:16 EDT
Description of problem:
Random, but highly reproducible compiler errors in Xen guest.


Version-Release number of selected component (if applicable):
Host OS: Latest F-7
Guest OS: Latest FC-6


How reproducible:
Install Host OS with F-7 on i386 machine (Intel Core Duo, tried 2GB and 4GB)
Install Xen Guest with FC-6, fully virtualized.
yum update on both systems.
Copy firefox.fc7.src.rpm to FC6 guest
Run
  rpmbuild --rebuild firefox.fc7.src.rpm
inside the FC6 guest.
Sooner or later I will get an "internal compiler error" together with the phrase
"likely hardware or OS problem".



Actual results:
Build does not complete.


Expected results:
Build should complete.


Additional info:
- I tried to completely re-install the guest, it appeared to help, but then the
problem came back.
- I did a full memtest86 on that machine, no errors.
- I have 4x 1GB modules in that machine, I tried with both combinations of 2x
1GB, still crashes.
- The host OS is able to compile the same src.rpm fine
Comment 1 Kai Engert (:kaie) (on vacation) 2007-07-04 13:36:13 EDT
The guest had either 500 MB or 1000 MB assigned.
Comment 2 Kai Engert (:kaie) (on vacation) 2007-07-04 14:17:39 EDT
For hardware info of this machine see
bug 240221 attachment 154769 [details]
bug 240221 attachment 154770 [details]
Comment 3 Kai Engert (:kaie) (on vacation) 2007-07-04 14:50:35 EDT
spooky!

all of the sudden my xen guest no longer has a network device eth0...

Then I decided to run an integrity test inside the xen guest:

rpm -qa | xargs -l rpm --verify

This gives me a lot of md5 sum mismatches, for binaries like /bin/vi ...
Comment 4 Kai Engert (:kaie) (on vacation) 2007-07-05 12:27:02 EDT
I spent a full day of experimenting with this issue and did a lot of re-installs
of the xen guest (keeping dom0 stable).


The lost network device is reproducible. I filed this as a separate bug 246808.
This tells me, right now, I must NOT update to latest FC6 updates in fully
virtualized machines.


I did a series of experiements with FC6 gold (original DVD ISO).

Paravirtualized, everything works perfectly.
FC6 original, and FC6 latest updates, no system corruption, I can compile
firefox reliably. Even with latest updates it's stable and networking is fine, too.

Fully virtualized, things are mostly ok.
My only problem here is the networking issue (bug 246808), but at that point I
gave up to try compiling.


Then I tried the FC6 respin ISO, which is a snapshot including FC6 updates as of
2007-04-01, installed as fully virtualized. http://torrent.fedoraunity.org/spins

This system is unstable.
I get the originally reported comiler errors.
(but no corruption yet).

So, in theory, the bug could be in that respin system? My original attempt (that
eventually resulted in the guest system corruption) was done using that respin
ISO, too.

Or is it more likely the bug is with the special combination of packages
included in the respin?

[root@fc6i3refu tmp]# rpm -qa | egrep -i 'xen|kernel|glibc'
glibc-common-2.5-10.fc6
kernel-2.6.20-1.2933.fc6
glibc-devel-2.5-10.fc6
kernel-devel-2.6.20-1.2933.fc6
glibc-headers-2.5-10.fc6
glibc-2.5-10.fc6
kernel-headers-2.6.20-1.2933.fc6

Comment 5 Richard W.M. Jones 2007-07-05 13:23:44 EDT
Disk corruption in fullvirt machines sounds suspiciously like what
I observed when running 32 bit FreeBSD fullvirt on F7.  See
bug 240009, in particular bug 240009 comment 9.
Comment 6 Bug Zapper 2008-05-14 09:24:23 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Bug Zapper 2008-06-16 21:47:15 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.