Bug 247528 (CVE-2007-3555)

Summary: CVE-2007-3555: moodle cross site scripting vulnerability
Product: [Fedora] Fedora Reporter: Ville Skytt√§ <ville.skytta>
Component: moodleAssignee: Gwyn Ciesla <gwync>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 7CC: fedora-security-list
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 1.8.2-1.fc7 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-08-06 17:58:14 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Ville Skyttä 2007-07-09 19:10:41 UTC
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2007-3555

"Cross-site scripting (XSS) vulnerability in index.php in Moodle 1.7.1 allows
remote attackers to inject arbitrary web script or HTML via a style expression
in the search parameter, a different vulnerability than CVE-2004-1424."

Appears to affect 1.6.x and 1.8.x too:
http://eduspaces.net/moodlenews/weblog/181794.html
http://download.moodle.org/stable18/CHANGES
http://download.moodle.org/stable16/CHANGES

Comment 1 Gwyn Ciesla 2007-07-25 23:52:19 UTC
Built 1.8.2 for rawhide, which addresses this.  Will push to 7, etc after testing.

Comment 2 Fedora Update System 2007-08-06 17:58:09 UTC
moodle-1.8.2-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.