Bug 249421

Summary: sort -R is not random
Product: [Fedora] Fedora Reporter: Scott Baker <bakers>
Component: coreutilsAssignee: Tim Waugh <twaugh>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 7   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-07-25 18:36:27 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Scott Baker 2007-07-24 12:45:01 EDT
Description of problem: sort -R is *not* random

Version-Release number of selected component (if applicable): coreutils-6.9-3.fc7

How reproducible:
Easy

Steps to Reproduce:
1. cat /etc/passwd | sort -R
  
Actual results:
Results are sorted alphabetically 

Expected results:
Results should be sorted randomly
Comment 1 Tim Waugh 2007-07-25 18:36:27 EDT

*** This bug has been marked as a duplicate of 249315 ***