Bug 250559

Summary: system-config-cluster doesn't recognize extended parameters
Product: [Retired] Red Hat Cluster Suite Reporter: Sergey Bykov <lion>
Component: redhat-config-clusterAssignee: Ryan McCabe <rmccabe>
Status: CLOSED ERRATA QA Contact: Cluster QE <mspqa-list>
Severity: medium Docs Contact:
Priority: low    
Version: 4CC: cluster-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-01-22 19:00:41 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 204097    

Description Sergey Bykov 2007-08-02 07:56:44 UTC
Description of problem:
I want to use quorum disk (Qdisk) with RHCS 4.5.
I use some specific parameters like "stop_cman" for <quorumd/> section and "tko"
for <heuristic/> section.
And when I start system-config-cluster it produce some error message:

Relax-NG validity error : Extra element quorumd in interleave
/etc/cluster/cluster.conf:2: element cluster: Relax-NG validity error : Element
cluster failed to validate content
/etc/cluster/cluster.conf fails to validate


Version-Release number of selected component (if applicable):
system-config-cluster-1.0.45-1.0
cman-1.0.17-0


How reproducible:
Always.

Steps to Reproduce:
1.Create new config with quorum disk.
2.Save this config and quit from system-config-cluster.
3.Edit /etc/cluster/cluster.conf and add some addition parameter (for example:
stop_cman) into <quorumd/> section.
4.Save config.
5.Start system-config-cluster.
  
Actual results:
Produce error message.

Expected results:


Additional info:

Comment 1 Sergey Bykov 2007-08-02 08:01:08 UTC
*** Bug 250560 has been marked as a duplicate of this bug. ***

Comment 2 Jim Parsons 2007-09-12 19:06:18 UTC
Fixed.

Comment 3 Lon Hohberger 2010-01-22 19:00:41 UTC
Both are included in system-config-cluster-1.0.54-2.0; not sure why this bug was not closed.